Mercurial > hg > openttd
graph
-
(svn r20957) -Codechange: Add another parameter to FindGRFConfig() to define search restrictions. draftSun, 17 Oct 2010 12:12:13 +0000, by frosch
-
(svn r20956) -Feature: Center new extra viewports on the tile below the mouse. Only center on center of main viewport if mouse is not in any viewport. draftSat, 16 Oct 2010 23:13:05 +0000, by frosch
-
(svn r20955) -Fix (r20952): Suppress bogus inconsistencies for games saved while Grfs were missing. draftSat, 16 Oct 2010 22:46:53 +0000, by frosch
-
(svn r20954) -Codechange (r20952, r20953): Don't make stuff more complicated than needed. draftSat, 16 Oct 2010 22:34:43 +0000, by frosch
-
(svn r20953) -Add: Resolve Grf filenames from the gamelog also using the md5sum. draftSat, 16 Oct 2010 21:20:46 +0000, by frosch
-
(svn r20952) -Add: When printing the gamelog keep track of added/removed Grfs and check them for consistency. draftSat, 16 Oct 2010 21:13:55 +0000, by frosch
-
(svn r20951) -Codechange: Add SmallMap::Contains() and use it. draftSat, 16 Oct 2010 20:34:43 +0000, by frosch
-
(svn r20950) -Fix: (or at least greatly improve) alignment of some original graphics pillar sprites draftSat, 16 Oct 2010 20:00:20 +0000, by rubidium
-
(svn r20947) -Change: Draw bridgepillars with correct length on all tile corners by drawing only half of the pillar sprite if required. (based on patch by uni657) draftSat, 16 Oct 2010 15:40:44 +0000, by frosch
-
(svn r20946) -Codechange: Add helper function to draw pillar columns. draftSat, 16 Oct 2010 15:36:51 +0000, by frosch
-
(svn r20945) -Codechange: Add helper function to draw single pillar sprites. (based on patch by uni657) draftSat, 16 Oct 2010 15:36:13 +0000, by frosch
-
(svn r20944) -Codechange: Bail out early in DrawBridgePillars(). (uni657) draftSat, 16 Oct 2010 15:35:32 +0000, by frosch
-
(svn r20943) -Codechange: Name some magic constants. (Based on patch by uni657) draftSat, 16 Oct 2010 15:34:59 +0000, by frosch
-
(svn r20942) -Feature [NewGRF]: make it possible to distinguish player built/randomly placed industries in the location and land slope check callbacks draftSat, 16 Oct 2010 13:15:54 +0000, by rubidium
-
(svn r20941) -Fix [FS#4163]: Readme referred to outdated behaviour draftSat, 16 Oct 2010 09:10:03 +0000, by planetmaker
-
(svn r20940) -Fix (r20928): switch to the normal alphabet where 'b' comes before 'p' draftSat, 16 Oct 2010 06:14:24 +0000, by yexo
-
(svn r20938) -Codechange: make the code for listening on a socket (more) reusable draftFri, 15 Oct 2010 21:56:06 +0000, by rubidium
-
(svn r20937) -Codechange: move some variables from client/server to server only draftFri, 15 Oct 2010 20:29:59 +0000, by rubidium
-
(svn r20936) -Codechange: make server side packet sending methods class methods draftFri, 15 Oct 2010 20:25:07 +0000, by rubidium
-
(svn r20935) -Codechange: only let the server side use a pool of connected sockets draftFri, 15 Oct 2010 19:58:56 +0000, by rubidium
-
(svn r20934) -Codechange: move NetworkGetClientName to the server's socket draftFri, 15 Oct 2010 19:35:08 +0000, by rubidium
-
(svn r20933) -Codechange: move some more client related methods and such to network_client.cpp draftFri, 15 Oct 2010 19:33:08 +0000, by rubidium
-
(svn r20932) -Add [FS#4153]: Highlight all destination tiles when building a lock. (uni657) draftFri, 15 Oct 2010 19:14:43 +0000, by terkhen
-
(svn r20931) -Document: Waterways toolbar click functions. draftFri, 15 Oct 2010 19:05:17 +0000, by terkhen
-
(svn r20930) -Codechange: simplify the socket handler allocation draftFri, 15 Oct 2010 18:45:56 +0000, by rubidium
-
(svn r20929) -Codechange: make NetworkCloseClient a class method draftFri, 15 Oct 2010 18:42:52 +0000, by rubidium
-
(svn r20927) -Add [FS#3905]: Transfer orders imply 'leave empty' by default draftFri, 15 Oct 2010 18:15:01 +0000, by planetmaker
-
(svn r20925) -Codechange: make the client send commands have a slightly more sensible name draftFri, 15 Oct 2010 14:29:13 +0000, by rubidium
-
(svn r20924) -Codechange: make the game connection packet handling look more like UDP/content packet handling draftFri, 15 Oct 2010 13:47:37 +0000, by rubidium
-
(svn r20923) -Codechange: prepare creating sub-classes of NetworkClientSocket for server and client side draftFri, 15 Oct 2010 13:22:00 +0000, by rubidium
-
(svn r20922) -Fix [FS#4071]: accidentally moving the mouse of the scrollbar arrows while pressing it clicks the button next to the arrow draftFri, 15 Oct 2010 11:16:14 +0000, by rubidium
-
(svn r20921) -Fix [FS#4160]: Refit costs were not shown for long cargo names. draftFri, 15 Oct 2010 10:22:04 +0000, by terkhen
-
(svn r20919) -Fix [FS#4140]: objects didn't change colour when the company changed colour. Now they do, except when the "decide colour" callback is (defined to be) used draftTue, 12 Oct 2010 19:48:42 +0000, by rubidium
-
(svn r20918) -Add: Store NewGRF version information from Action14 in savegame. (planetmaker) draftTue, 12 Oct 2010 17:47:15 +0000, by frosch
-
(svn r20913) -Fix (r19231): [NoAI] give the correct error message if you try to overbuild an opponont road station with your own while using the 0.7 or 1.0 compatibility layer (fanioz) draftSun, 10 Oct 2010 15:33:22 +0000, by yexo
-
(svn r20912) -Fix [FS#4157]: NEW_INDUSTRYOFFSET != NEW_INDUSTRYTILEOFFSET. draftSat, 09 Oct 2010 18:43:37 +0000, by frosch
-
(svn r20910) -Fix [FS#4155]: helicopters fired a bit too late draftFri, 08 Oct 2010 21:23:41 +0000, by rubidium
-
(svn r20909) -Fix [FS#4137]: don't see coasts as water for object construction draftFri, 08 Oct 2010 21:08:38 +0000, by rubidium
-
(svn r20908) -Fix [FS#4156]: assertion when the buy menu graphics callback accessed a variable that needs a tile index draftFri, 08 Oct 2010 21:07:54 +0000, by rubidium
-
(svn r20907) -Fix [FS#4156-ish]: callback 15C's string didn't actually get drawn draftFri, 08 Oct 2010 20:33:23 +0000, by rubidium
-
(svn r20902) -Fix [FS#4032]: Make IsProductionAlterable() work for most NewGRF industries. draftMon, 04 Oct 2010 20:20:50 +0000, by frosch
-
(svn r20901) -Fix/Change: When using non-smooth or newgrf-economy changing production rates does not work (anymore), so allow changing the production multiplier instead. draftMon, 04 Oct 2010 20:12:38 +0000, by frosch
-
(svn r20900) -Codechange: Move ProductionLevels enum to industry.h draftMon, 04 Oct 2010 20:10:31 +0000, by frosch
-
(svn r20899) -Codechange: Switch order of if-tests in IndustryViewWindow::OnClick(). draftMon, 04 Oct 2010 20:00:23 +0000, by frosch
-
(svn r20898) -Change: When entering a production rate, round to nearest possible rate instead towards zero. draftMon, 04 Oct 2010 19:45:27 +0000, by frosch
-
(svn r20897) -Codechange: Store the result of IsProductionAlterable() in a member variable of IndustryViewWindow. draftMon, 04 Oct 2010 19:35:40 +0000, by frosch