Mercurial > hg > openttd
graph
-
(svn r6280) -Codechange: Use the same naming for trains as for other vehicles: draftThu, 31 Aug 2006 15:57:38 +0000, by Darkvater
-
(svn r6279) -Codechange (r1525): Use proper const pointers for functions that do not change them . draftThu, 31 Aug 2006 15:28:11 +0000, by Darkvater
-
(svn r6278) -Revert the colour-mess in the vehicle window for ships, fourwheelers and draftThu, 31 Aug 2006 15:22:40 +0000, by Darkvater
-
(svn r6277) Clean up the train details drawing routine draftThu, 31 Aug 2006 15:22:03 +0000, by tron
-
(svn r6273) Clean up the custom currency window handler a bit draftThu, 31 Aug 2006 14:12:08 +0000, by tron
-
(svn r6272) -Revert the colour-mess in the vehicle window. Servicing depot destinations draftThu, 31 Aug 2006 14:01:28 +0000, by Darkvater
-
(svn r6270) Remove the "unsorted" vehicle sorter, because it's plain useless draftThu, 31 Aug 2006 13:33:25 +0000, by tron
-
(svn r6269) -Fix r6240: fixed incorrect row count in vehicle lists when resizing to smaller windows (AsterixMG) draftThu, 31 Aug 2006 13:28:59 +0000, by bjarni
-
(svn r6268) Remove now pointless assignment (followup of r6267) draftThu, 31 Aug 2006 12:19:32 +0000, by tron
-
(svn r6267) Simplify the control flow in the rail tile loop by eliminating a bool flag and replacing it by a simple goto draftThu, 31 Aug 2006 11:42:16 +0000, by tron
-
(svn r6266) Replace four shifts by a single multiplication and let the compiler handle what to do with it - it does a better job draftThu, 31 Aug 2006 11:25:00 +0000, by tron
-
(svn r6265) Check whether to draw catenary at all once before the drawing loop instead of on every iteration draftThu, 31 Aug 2006 11:18:30 +0000, by tron
-
(svn r6263) WebTranslator2 update to 2006-08-31 12:34:27 draftThu, 31 Aug 2006 10:34:59 +0000, by miham
-
(svn r6262) Remove unused #define and function declaration draftThu, 31 Aug 2006 10:14:47 +0000, by tron
-
(svn r6261) -Fix r6246: fixed sprite related crash related to other player's vehicle list windows (spotted by Darkvater) draftThu, 31 Aug 2006 09:40:10 +0000, by bjarni
-
(svn r6259) Extract the axis directly, don't use a trinary operator draftThu, 31 Aug 2006 08:16:28 +0000, by tron
-
(svn r6258) Reduce the number of induction variables and inner scopes for clarity draftThu, 31 Aug 2006 08:11:08 +0000, by tron
-
(svn r6257) Use memcmp() to check the MD5 sum instead of using a home brewed loop draftThu, 31 Aug 2006 07:52:20 +0000, by tron
-
(svn r6253) Comment out code with #if 0, not //. Join statements which needlessly span many lines into fewer lines draftThu, 31 Aug 2006 07:09:13 +0000, by tron
-
(svn r6252) Replace a comglomerate of ifs for animated station tiles by a small table and a loop iterating over it draftThu, 31 Aug 2006 07:01:26 +0000, by tron
-
(svn r6251) Replace 2 bool variables by a simple switch draftThu, 31 Aug 2006 06:46:52 +0000, by tron
-
(svn r6249) -Fix: fixed assert when pressing goto depot in an empty list (forgot to disable the button in this condition) draftWed, 30 Aug 2006 23:01:45 +0000, by bjarni
-
(svn r6247) -Fix(r6244): invalid arguments caused infinite loop draftWed, 30 Aug 2006 22:32:25 +0000, by glx
-
(svn r6246) -Feature: added the many times requested "send all vehicle to depot" button draftWed, 30 Aug 2006 21:39:01 +0000, by bjarni
-
(svn r6245) -Add: added comments for all YAPF C interface functions (yapf.h) used by other modules, added FollowTrackInit() into YAPF track followers. draftWed, 30 Aug 2006 21:10:25 +0000, by KUDr
-
(svn r6244) -Fix: allow any order for strgen parameters draftWed, 30 Aug 2006 20:08:58 +0000, by glx
-
(svn r6243) -Codechange: made SortVehicleList() static as well since that one is not used in any other files either (Thanks Tron for pointing this out) draftWed, 30 Aug 2006 19:49:46 +0000, by bjarni
-
(svn r6242) -Codechange: made BuildVehicleList static as it is not used in any other files anymore draftWed, 30 Aug 2006 19:42:20 +0000, by bjarni
-
(svn r6241) -Fix r6240: missed altering one line in last commit draftWed, 30 Aug 2006 19:10:12 +0000, by bjarni
-
(svn r6240) -Code cleanup: in PlayerVehWndProc: replaced size_of_row with w->resize.step_height draftWed, 30 Aug 2006 18:35:02 +0000, by bjarni
-
(svn r6239) -Code cleanup: cleaned up PlayerVehWndProc draftWed, 30 Aug 2006 16:32:00 +0000, by bjarni
-
(svn r6238) Use the colour stored in _colour_gradient[] instead of explicitly retrieving it with GetNonSprite() draftWed, 30 Aug 2006 14:30:26 +0000, by tron
-
(svn r6237) -Fix r6165: fixed wrong hangar name in heading for hangar strings draftWed, 30 Aug 2006 13:41:53 +0000, by bjarni
-
(svn r6236) -Fix (FS#313): TGP generation seed edit box only accepted seeds up to 2^31-1, instead of up to 2^32-2. draftWed, 30 Aug 2006 12:37:04 +0000, by rubidium
-
(svn r6235) -Cleanup: Make SVN ignore everything not under version control in the data/ folder draftWed, 30 Aug 2006 09:29:20 +0000, by Darkvater
-
(svn r6229) -Feature: Shared order lists now got a "goto depot" button draftTue, 29 Aug 2006 23:39:57 +0000, by bjarni
-
(svn r6228) -Fix: redrawing an empty list of shared vehicles will now close the window draftTue, 29 Aug 2006 22:47:38 +0000, by bjarni
-
(svn r6227) -Codechange: added window type flags to use with PlayerVehWndProc draftTue, 29 Aug 2006 21:36:39 +0000, by bjarni
-
(svn r6226) -Fix(r5864): an assertion was triggered when drawing catenary on steep slopes (TrueLight) draftTue, 29 Aug 2006 21:34:02 +0000, by glx
-
(svn r6225) -Codechange: change the warning/error format of strgen to show up draftTue, 29 Aug 2006 20:55:25 +0000, by Darkvater
-
(svn r6224) WebTranslator2 update to 2006-08-29 22:34:42 draftTue, 29 Aug 2006 20:35:07 +0000, by miham
-
(svn r6222) Remove struct ColorList, because the names of its attributes are plain confusing draftTue, 29 Aug 2006 19:26:13 +0000, by tron
-
(svn r6220) -Fix: added missing space in a string for Catalan town names (Arnau) draftTue, 29 Aug 2006 18:50:15 +0000, by bjarni
-
(svn r6215) -Codechange: [vehicle list windows] unified Player(vehicle)WndProc into PlayerVehWndProc draftTue, 29 Aug 2006 17:41:13 +0000, by bjarni
-
(svn r6213) -Fix: Calatan town names was only prefix OR the rest of the string, never both (nars) draftTue, 29 Aug 2006 14:45:39 +0000, by bjarni
-
(svn r6212) Remove dependency on window.h from station.h draftTue, 29 Aug 2006 06:50:47 +0000, by tron
-
(svn r6210) Remove FR_NOBORDER, because it is exclusivly used in conjunction with FR_TRANSPARENT draftTue, 29 Aug 2006 06:39:00 +0000, by tron
-
(svn r6209) Move DrawFrameRect() out of gfx.[ch], because it uses data (_color_list) which the renderer shouldn't have know about draftTue, 29 Aug 2006 06:07:57 +0000, by tron
-
(svn r6208) Reduce the number of induction variables for clarity draftTue, 29 Aug 2006 06:03:26 +0000, by tron