Mercurial > hg > openttd
graph
-
(svn r21902) -Fix: Do not count articulated parts when passing the number of vehicles to refit to the command. That may exceed 8 bits. draftSun, 23 Jan 2011 14:58:54 +0000, by frosch
-
(svn r21901) -Codechange: Save some bits in p2 of CmdRefitVehicle. draftSun, 23 Jan 2011 13:25:26 +0000, by frosch
-
(svn r21900) -Fix: [NoAI] hide automatic orders from AIs as they have no way of dealing with them draftSun, 23 Jan 2011 13:08:50 +0000, by yexo
-
(svn r21899) -Fix: Do not show a vehicle selection in the RefitWindow for refit orders. You cannot select anything anyway. draftSun, 23 Jan 2011 13:00:50 +0000, by frosch
-
(svn r21898) -Fix [FS#4438]: using a pointer-iterator and adding things (thus reallocating) to the iterated array caused OpenTTD to crash on invalid pointers draftSun, 23 Jan 2011 11:20:55 +0000, by rubidium
-
(svn r21897) -Fix (21707): Kenobi visited IsValidConsoleColour shortly draftSun, 23 Jan 2011 00:11:15 +0000, by rubidium
-
(svn r21896) -Cleanup: remove the unused StartScenario draftSat, 22 Jan 2011 23:13:39 +0000, by rubidium
-
(svn r21895) -Cleanup: get rid of the unused SLD_NEW_GAME draftSat, 22 Jan 2011 23:08:32 +0000, by rubidium
-
(svn r21894) -Cleanup: get rid of the unused SM_START_SCENARIO draftSat, 22 Jan 2011 23:08:18 +0000, by rubidium
-
(svn r21893) -Update (r21892): remove the strings from the other language files as well draftSat, 22 Jan 2011 23:07:51 +0000, by rubidium
-
(svn r21892) -Fix [FS#4421]: only some scenarios from the main scenario folder and no heightmaps could be started in the "start server" window draftSat, 22 Jan 2011 23:07:23 +0000, by rubidium
-
(svn r21890) -Cleanup: remove some unneeded includes draftSat, 22 Jan 2011 14:52:20 +0000, by rubidium
-
(svn r21889) -Fix [FS#4434]: crash when scrolling outside of the main window (with some video backends) draftSat, 22 Jan 2011 14:51:36 +0000, by rubidium
-
(svn r21888) -Codechange: remove some unneeded (for the AI header) headers from some AI headers, reducing the include tree draftSat, 22 Jan 2011 10:33:16 +0000, by rubidium
-
(svn r21887) -Fix-ish: some headers weren't including the headers they depend on draftSat, 22 Jan 2011 10:10:03 +0000, by rubidium
-
(svn r21886) -Codechange: move documentation towards the code to make it more likely to be updated [n]. draftSat, 22 Jan 2011 09:53:15 +0000, by rubidium
-
(svn r21885) -Fix [FS#4422]: NewGRF string codes 0x80 and 0x81 were broken since the typechecking of string parameters draftFri, 21 Jan 2011 23:10:02 +0000, by yexo
-
(svn r21883) -Codechange: make UpdateZPosition() faster by not calling GetSlopeZ() when not needed draftFri, 21 Jan 2011 17:35:17 +0000, by smatz
-
(svn r21882) -Codechange: make use of the fact that vehicle's Z position can change only if it has GVF_GOINGUP_BIT or GVF_GOINGDOWN_BIT set draftFri, 21 Jan 2011 16:51:56 +0000, by smatz
-
(svn r21881) -Codechange: ensure that vehicle's GOINGUP/DOWN bits are set correctly and that it has correct z_pos when converting from older savegames draftFri, 21 Jan 2011 16:48:41 +0000, by smatz
-
(svn r21880) -Fix: when a train after reversing ended at the last bit of a bridge ramp and directed outside the bridge, it could still have track set to TRACK_BIT_WORMHOLE draftFri, 21 Jan 2011 16:35:12 +0000, by smatz
-
(svn r21879) -Codechange: reset vehicle's GOINGUP/DOWN bits when it crashes draftFri, 21 Jan 2011 16:20:55 +0000, by smatz
-
(svn r21878) -Codechange: move parts of UpdateInclination() to separate functions draftFri, 21 Jan 2011 16:13:54 +0000, by smatz
-
(svn r21877) -Codechange: move definition of HALF_TILE_SIZE to tile_type.h draftFri, 21 Jan 2011 15:48:52 +0000, by smatz
-
(svn r21876) -Codechange: typedef SpecializedVehicleBase and GroundVehicleBase to reduce typing draftFri, 21 Jan 2011 14:43:38 +0000, by smatz
-
(svn r21875) -Codechange: indentation of some comments was wrong draftFri, 21 Jan 2011 01:38:30 +0000, by smatz
-
(svn r21874) -Fix: when a single-vehicle train was reversed while on a slope, its GOINGUP/DOWN weren't swapped draftFri, 21 Jan 2011 00:11:13 +0000, by smatz
-
(svn r21872) -Doc: update some more documentation draftThu, 20 Jan 2011 22:09:31 +0000, by rubidium
-
(svn r21871) -Doc: terraforming/clearing limits (dihedral) draftThu, 20 Jan 2011 22:03:27 +0000, by rubidium
-
(svn r21870) -Doc: Mention 'joan' in the admin network documentation. draftThu, 20 Jan 2011 21:28:38 +0000, by frosch
-
(svn r21868) -Fix (r21866 and some more): the changes to the main toolbar rail types dropdown should happen for the autoreplace dropdown as well draftThu, 20 Jan 2011 12:40:40 +0000, by rubidium
-
(svn r21867) -Codechange: move creating the rail type dropdown to a more general location draftThu, 20 Jan 2011 12:40:04 +0000, by rubidium
-
(svn r21866) -Feature [FS#4394]: [NewGRF] Rail type property to influence sorting of rail types in the drop down list draftThu, 20 Jan 2011 12:22:38 +0000, by rubidium
-
(svn r21865) -Fix (r21862): don't perform savegame conversion when reinitialising some vehicle structures due to NewGRF changes draftThu, 20 Jan 2011 09:35:16 +0000, by rubidium
-
(svn r21864) -Fix [FS#4430]: distant-join station would build at the wrong location when having persistent building turned on and selecting a "second" location for the station tile draftWed, 19 Jan 2011 23:59:29 +0000, by rubidium
-
(svn r21863) -Fix (r21849): load the amount that should be loaded instead of the amount that should not be loaded draftWed, 19 Jan 2011 20:40:27 +0000, by rubidium
-
(svn r21862) -Codechange: Unify subtype handling between road vehicles and trains. draftWed, 19 Jan 2011 20:04:09 +0000, by terkhen
-
(svn r21860) -Codechange: Rename road vehicle subtype functions to match the train names. draftWed, 19 Jan 2011 18:44:13 +0000, by terkhen
-
(svn r21859) -Codechange: Move train subtype flags to GroundVehicle. draftWed, 19 Jan 2011 18:42:54 +0000, by terkhen
-
(svn r21858) -Codechange: Give more similar names to ArticulatedPart functions. draftWed, 19 Jan 2011 18:41:53 +0000, by terkhen
-
(svn r21857) -Add: Revision detection for hgsubversion repositories. draftWed, 19 Jan 2011 17:10:57 +0000, by michi_cc
-
(svn r21856) -Fix (r21840): Don't fail tag detection on hg repositories that use mercurial queues. Add some safety against tags and branches with spaces as well. draftWed, 19 Jan 2011 17:10:52 +0000, by michi_cc
-
(svn r21855) -Feature [FS#4368]: [Network] Console command to change the password of other companies for servers (dihedral) draftWed, 19 Jan 2011 16:52:57 +0000, by rubidium
-
(svn r21854) -Codechange: refactor the password setting methods to make it possible to change the password of other companies (on the server) draftWed, 19 Jan 2011 16:47:40 +0000, by rubidium
-
(svn r21853) -Codechange: HashCurrentCompanyPassword is only used by servers, so move it to network_server.* (dihedral) draftWed, 19 Jan 2011 16:37:06 +0000, by rubidium
-
(svn r21852) -Codechange: generalise GenerateCompanyPasswordHash (dihedral) draftWed, 19 Jan 2011 16:35:11 +0000, by rubidium
-
(svn r21851) -Codechange: rename NetworkClientSetPassword to NetworkClientSetCompanyPassword (dihedral) draftWed, 19 Jan 2011 16:32:23 +0000, by rubidium
-
(svn r21850) -Codechange: move password hashing to a more general location (dihedral) draftWed, 19 Jan 2011 16:30:09 +0000, by rubidium
-
(svn r21849) -Codechange: move merging/splitting of cargopackets into a helper function (fonsinchen) draftWed, 19 Jan 2011 16:25:00 +0000, by rubidium
-
(svn r21848) -Codechange: unification of comment style for cargopacket.* draftWed, 19 Jan 2011 16:20:26 +0000, by rubidium
-
(svn r21847) -Fix [FS#4423]: slowing down of trains was done by reducing the speed by 10%, but also when you're just 1% too fast, so limit the slowdown till the new maximum speed draftWed, 19 Jan 2011 08:24:38 +0000, by rubidium
-
(svn r21846) -Codechange: move documentation towards the code to make it more likely to be updated [o-s]. draftTue, 18 Jan 2011 23:09:43 +0000, by rubidium
-
(svn r21845) -Codechange: move documentation towards the code to make it more likely to be updates [d-m]. draftTue, 18 Jan 2011 22:31:06 +0000, by rubidium
-
(svn r21844) -Codechange: move documentation towards the code to make it more likely to be updates [a-c]. draftTue, 18 Jan 2011 22:17:15 +0000, by rubidium
-
(svn r21843) -Codechange: move documentation towards the code to make it more likely to be updates [t-z]. draftTue, 18 Jan 2011 21:58:22 +0000, by rubidium
-
(svn r21842) -Feature [FS#4393]: [NewGRF] Introduction dates/required types for rail types; e.g. introduce a particular rail type in 1960 (or when a vehicle using it is introduced), but also allow limiting its introduction to only happen when the required railtypes are available draftTue, 18 Jan 2011 21:30:59 +0000, by rubidium