Mercurial > hg > openttd
graph
-
(svn r12753) -Codechange: do not use IsDepotTypeTile() where simpler function can be used draftThu, 17 Apr 2008 18:24:45 +0000, by smatz
-
(svn r12752) -Codechange: replace some magic constants in player_gui.cpp. Patch by Yexo. draftThu, 17 Apr 2008 18:12:53 +0000, by rubidium
-
(svn r12751) -Codechange: do what has been done in r11862 in a different way so it uses less memory. draftThu, 17 Apr 2008 11:47:22 +0000, by rubidium
-
(svn r12750) -Fix (r12749): viewport for industry new messages was not shown properly. draftThu, 17 Apr 2008 11:25:12 +0000, by rubidium
-
(svn r12749) -Codechange: store the viewport information in the windows that have a viewport instead of one global array with a viewport for each window, even when they do not use the viewport. draftThu, 17 Apr 2008 09:42:44 +0000, by rubidium
-
(svn r12747) -Codechange: Add varaction retrieval of station animation frame draftThu, 17 Apr 2008 06:53:52 +0000, by peter1138
-
(svn r12746) -Codechange: Add map storage for station animation frame draftThu, 17 Apr 2008 06:52:56 +0000, by peter1138
-
(svn r12745) -Codechange: a bit of naming conventions, introduce Is*DepotTile() draftThu, 17 Apr 2008 00:44:20 +0000, by smatz
-
(svn r12741) -Codechange: do not allocate the viewport drawer each time on the stack, but only once and reuse this. draftWed, 16 Apr 2008 21:06:21 +0000, by rubidium
-
(svn r12740) -Codechange: use a vector instead of allocating memory in a byte array for ChildScreenSpriteToDraw. draftWed, 16 Apr 2008 20:39:35 +0000, by rubidium
-
(svn r12739) -Codechange: use a vector instead of allocating memory in a byte array for ParentSpriteToDraw. draftWed, 16 Apr 2008 20:01:04 +0000, by rubidium
-
(svn r12738) -Fix (r12736): some sprites could be left unsorted draftWed, 16 Apr 2008 19:36:30 +0000, by smatz
-
(svn r12737) -Codechange: Replace vector with a cut down class to allocate space as necessary. This avoids copying data around for vector's push_back() function. draftWed, 16 Apr 2008 19:01:09 +0000, by peter1138
-
(svn r12736) -Codechange: a (small) touch of coding style in viewport.cpp. draftWed, 16 Apr 2008 18:28:05 +0000, by rubidium
-
(svn r12735) -Codechange: use a vector instead of allocating memory in a byte array for TileSpriteToDraw. draftWed, 16 Apr 2008 14:18:15 +0000, by rubidium
-
(svn r12734) -Codechange: use a vector instead of allocating memory in a big byte array for StringSpriteToDraw. draftWed, 16 Apr 2008 14:15:00 +0000, by rubidium
-
(svn r12733) -Codechange: Merge two more Widgets arrays (town views ) into one. draftWed, 16 Apr 2008 03:05:56 +0000, by belugas
-
(svn r12731) -Fix (r12726): copying a 16bit array into 32bit wouldn't work draftTue, 15 Apr 2008 23:07:06 +0000, by smatz
-
(svn r12726) -Fix [FS#1877]: overflow causing strange building behaviour in towns. draftTue, 15 Apr 2008 22:27:28 +0000, by rubidium
-
(svn r12717) -Fix (r11107): Check the TILE_NOT_SLOPED flag of the _north_ tile of multi-tile houses to decide if autoslope is allowed. draftTue, 15 Apr 2008 13:10:01 +0000, by frosch
-
(svn r12716) -Fix: Do not compare StationIDs with DepotIDs or WaypointIDs. draftTue, 15 Apr 2008 12:25:35 +0000, by frosch
-
(svn r12714) -Fix [FS#1904]: do not move windows below the toolbar on resizes unless they would go behind the toolbar. draftMon, 14 Apr 2008 23:26:31 +0000, by rubidium
-
(svn r12713) -Fix: misleading comment. Patch by Yexo. draftMon, 14 Apr 2008 21:49:13 +0000, by rubidium
-
(svn r12709) -Feature: show the last joined server. Heavily based on a patch by Yexo. draftMon, 14 Apr 2008 20:31:21 +0000, by rubidium
-
(svn r12708) -Fix (FS#1914): increase default sound buffer size only for vista draftMon, 14 Apr 2008 20:14:32 +0000, by glx
-
(svn r12707) -Fix: do not crash very hard on unrecognised savegames, just go back to the intro menu instead. draftMon, 14 Apr 2008 20:00:28 +0000, by rubidium
-
(svn r12706) -Merge: the thread rewrite from NoAI. The rewrite makes the threading we have better extendable. draftMon, 14 Apr 2008 19:54:33 +0000, by rubidium
-
(svn r12705) -Codechange: enumification of some more widgets draftMon, 14 Apr 2008 17:50:15 +0000, by belugas
-
(svn r12704) -Codechange: code style cleanup, mostly switch case alignment draftMon, 14 Apr 2008 17:06:36 +0000, by belugas
-
(svn r12701) -Codechange: do not explicitly number a widget enum because that causes a big diff when adding something. draftMon, 14 Apr 2008 13:23:16 +0000, by rubidium
-
(svn r12700) -Cleanup (r12699): Remove an unused string. draftMon, 14 Apr 2008 12:42:01 +0000, by maedhros
-
(svn r12699) -Codechange: Unify the order drawing code for orders and timetables. draftMon, 14 Apr 2008 12:40:09 +0000, by maedhros
-
(svn r12698) -Codechange: skip orders to stations that do not have a train part anymore, just like is done for road vehicles and ships. draftMon, 14 Apr 2008 07:08:43 +0000, by rubidium
-
(svn r12697) -Codechange: give signs_gui.cpp a touch of coding style. draftSun, 13 Apr 2008 22:25:18 +0000, by rubidium
-
(svn r12696) -Fix: loading ancient savegames could result in invalid orders in order lists with all related problems. draftSun, 13 Apr 2008 19:46:26 +0000, by rubidium
-
(svn r12695) -Codechange: only allocate window structs when needed. Based on a patch by Alberth. draftSun, 13 Apr 2008 19:25:14 +0000, by rubidium
-
(svn r12694) -Fix: do not call the mouse over callback on already deleted windows. draftSun, 13 Apr 2008 19:06:30 +0000, by rubidium
-
(svn r12693) -Documentation: add some documentation to some window related stuff. Based on a patch by Albert. draftSun, 13 Apr 2008 19:01:26 +0000, by rubidium
-
(svn r12692) -Codechange: swap to functions to remove a function declaration. draftSun, 13 Apr 2008 18:59:32 +0000, by rubidium
-
(svn r12691) -Fix (r12459): all company related news displayed the 'company is in trouble' message draftSun, 13 Apr 2008 17:59:43 +0000, by glx
-
(svn r12690) -Cleanup: remove unused table from tgp.cpp draftSun, 13 Apr 2008 17:27:36 +0000, by smatz
-
(svn r12689) -Feature: non-stop(or rather no non-stop) and via orders for road vehicles. draftSun, 13 Apr 2008 16:54:19 +0000, by rubidium
-
(svn r12688) -Change: make default non-stop for depot/waypoint orders the same as for stations. draftSun, 13 Apr 2008 16:50:55 +0000, by rubidium
-
(svn r12687) -Change: show when a vehicle is actually leaving the station instead of loading/unloading. draftSun, 13 Apr 2008 16:48:28 +0000, by rubidium
-
(svn r12685) -Codechange: DebugDumpCommands() couldn't be inlined, define it as a macro instead draftSun, 13 Apr 2008 14:19:08 +0000, by smatz
-
(svn r12684) -Fix [FS#1891]: manually given service at depot order is not forgotten anymore when autoservice 'interferes'. draftSun, 13 Apr 2008 11:35:57 +0000, by rubidium
-
(svn r12683) -Fix [FS#1906]: in some cases a news messages would not be shown. draftSun, 13 Apr 2008 11:15:48 +0000, by rubidium
-
(svn r12682) -Fix [FS#1920]: removing road pieces from a town gave you twice the intended penalty. draftSun, 13 Apr 2008 10:32:29 +0000, by rubidium
-
(svn r12681) -Fix [FS#1921]: aircraft stopping mid-air. draftSun, 13 Apr 2008 10:26:39 +0000, by rubidium
-
(svn r12679) -Codechange : a little bit of widget enumification draftSun, 13 Apr 2008 01:51:12 +0000, by belugas
-
(svn r12678) -Fix [FS#1918]: when a road vehicle has a tram only stop multiple times in a row in it's orders, only the first one would be skipped. draftSat, 12 Apr 2008 22:40:56 +0000, by rubidium
-
(svn r12676) -Codechange: Reinstate colour selection buses, absent since r6455. draftSat, 12 Apr 2008 22:19:34 +0000, by peter1138
-
(svn r12675) -Codechange: Add support for custom drawing of drop down list items. draftSat, 12 Apr 2008 22:12:27 +0000, by peter1138
-
(svn r12674) -Fix [FS#1902]: Colour remaps on station sprites only worked for company colours. draftSat, 12 Apr 2008 22:11:21 +0000, by peter1138
-
(svn r12672) -Codechange: Add support for variably-sized drop down list items. draftSat, 12 Apr 2008 20:32:18 +0000, by peter1138
-
(svn r12671) -Fix (r12644): orders window of competitors' vehicles was missing a resizebox draftSat, 12 Apr 2008 20:15:57 +0000, by smatz
-
(svn r12670) -Add: unconditional/always order 'jump/skip' variable. draftSat, 12 Apr 2008 13:07:25 +0000, by rubidium
-
(svn r12669) -Fix (r12667): crash when a vehicle has never been to a station and the load percentage conditional variable is evaluated. draftSat, 12 Apr 2008 12:51:16 +0000, by rubidium
-
(svn r12668) -Fix (12667): swapping of variables went wrong. draftSat, 12 Apr 2008 12:19:53 +0000, by rubidium
-
(svn r12667) -Feature: conditional 'skip/jump' orders. draftSat, 12 Apr 2008 11:58:19 +0000, by rubidium
-
(svn r12666) -Fix: the time table GUI did not show some data in the correct manner. draftSat, 12 Apr 2008 11:15:25 +0000, by rubidium
-
(svn r12665) -Codechange: make the internal speed <-> display speed conversions available to a bigger part of the code. draftSat, 12 Apr 2008 10:00:52 +0000, by rubidium
-
(svn r12664) -Codechange: do not force the 'color' pointer to be non-NULL when trying to get the load percentage. draftSat, 12 Apr 2008 09:59:58 +0000, by rubidium
-
(svn r12663) -Codechange: move the definition from 'order_d' to a more appropriate place and do not misuse it for the time table GUI. draftFri, 11 Apr 2008 21:19:03 +0000, by rubidium
-
(svn r12662) -Codechange: Comment-code style application draftFri, 11 Apr 2008 18:00:51 +0000, by belugas
-
(svn r12661) -Add: ability to send a vehicle (using default orders) to the nearest depot. draftFri, 11 Apr 2008 15:58:46 +0000, by rubidium
-
(svn r12660) -Codechange: make the creation of depot order strings a little more modular (instead of causing a string explosion). draftFri, 11 Apr 2008 14:27:18 +0000, by rubidium
-
(svn r12659) -Cleanup: some style cleanups in vehicle.cpp. draftFri, 11 Apr 2008 13:19:44 +0000, by rubidium
-
(svn r12658) -Codechange: unify a vast portion of the CmdSend<VehicleType>ToDepot commands. draftFri, 11 Apr 2008 08:40:10 +0000, by rubidium
-
(svn r12657) -Codechange: add 'FindClosestDepot' to the vehicle class. draftFri, 11 Apr 2008 08:14:43 +0000, by rubidium
-
(svn r12656) -Fix: tooltips for some order buttons are outdated/incorrect. draftThu, 10 Apr 2008 22:18:33 +0000, by rubidium
-
(svn r12655) -Change: show the current state in the drop down 'buttons'. draftThu, 10 Apr 2008 22:17:06 +0000, by rubidium
-
(svn r12654) -Codechange: remove some unneeded right click handling due to the splitting of the load/refit button. draftThu, 10 Apr 2008 22:07:24 +0000, by rubidium
-
(svn r12653) -Codechange: disable load/unload dropdowns when there is a 'via' non-stop order to emphasize that loading/unloading will not be done. draftThu, 10 Apr 2008 17:52:48 +0000, by rubidium
-
(svn r12652) -Codechange: rework the order GUI a little more to make it a little more clear that 'transfer' is just an unload type. draftThu, 10 Apr 2008 17:23:51 +0000, by rubidium
-
(svn r12651) -Fix (r12644) [FS#1915]: Dropdown widget width should be one pixel less than window width, not one more. draftThu, 10 Apr 2008 11:59:18 +0000, by peter1138
-
(svn r12650) -Feature: ability to force a vehicle to not load at a station. draftThu, 10 Apr 2008 10:18:03 +0000, by rubidium
-
(svn r12648) -Feature: allow four different non-stop types in a single game instead of two. The "TTDP compatible order" setting now only sets the default behaviour of new trains. draftThu, 10 Apr 2008 08:30:15 +0000, by rubidium
-
(svn r12647) -Codechange: Ooops... Too fast on the job... forgot to indent 3 lines draftThu, 10 Apr 2008 02:23:38 +0000, by belugas
-
(svn r12646) -Codechange: another run of code-style cleanup draftThu, 10 Apr 2008 02:14:14 +0000, by belugas
-
(svn r12645) -Codechange: a bit of code-style cleanup draftThu, 10 Apr 2008 02:10:26 +0000, by belugas
-
(svn r12644) -Codechange: rework the order gui a little to prepare it for some future changes. draftWed, 09 Apr 2008 23:00:12 +0000, by rubidium
-
(svn r12643) -Codechange: be more explicit about the orders a vehicle has (non stop and full load are ambiguous and depend on some patch settings). draftWed, 09 Apr 2008 22:01:23 +0000, by rubidium
-
(svn r12642) -Fix: remove buggy buoys at tile 0 from old TTDP savegames draftWed, 09 Apr 2008 21:33:36 +0000, by smatz
-
(svn r12641) -Codechange: do not use the same button for two completely distinct tasks, just make an extra button for it and hide them when not needed. draftWed, 09 Apr 2008 19:52:33 +0000, by rubidium
-
(svn r12640) -Codechange: let GetLoadType make a difference between full load and full load any based on the patch setting instead of using the patch setting directly. draftWed, 09 Apr 2008 18:26:19 +0000, by rubidium
-
(svn r12639) -Fix: order window was not marked dirty on changed orders. draftWed, 09 Apr 2008 17:48:22 +0000, by rubidium
-
(svn r12638) -Codechange: give order_gui.cpp a touch of coding style. draftWed, 09 Apr 2008 16:16:04 +0000, by rubidium
-
(svn r12637) -Fix [FS#1913]: possible NULL pointer dereference when reading some NewGRF data. draftWed, 09 Apr 2008 14:05:50 +0000, by rubidium
-
(svn r12636) -Codechange: make CmdModifyOrder a little more flexible and remove 'hack' that used the full load flag to set the service if needed flag. draftWed, 09 Apr 2008 12:46:43 +0000, by rubidium
-
(svn r12635) -Codechange: a bit of a code-style cleanup draftWed, 09 Apr 2008 02:16:04 +0000, by belugas
-
(svn r12634) -Feature: Financial and Player Selection Face windows are now remembering their position when toggling sizes draftWed, 09 Apr 2008 02:02:39 +0000, by belugas
-
(svn r12633) -Fix: could not make a (go-to) depot order. draftTue, 08 Apr 2008 22:41:14 +0000, by rubidium
-
(svn r12632) -Fix (r12547): with invisible catenary, trams were be drawn over a bridge draftTue, 08 Apr 2008 21:28:47 +0000, by smatz
-
(svn r12631) -Fix [FS#1911]: sometimes aircraft couldn't find their way to their depot. draftTue, 08 Apr 2008 18:53:25 +0000, by rubidium
-
(svn r12630) -Fix (r12600): Missing 'break' made it impossible to add waypoints to vehicle orders. draftTue, 08 Apr 2008 16:15:31 +0000, by maedhros
-
(svn r12629) -Codechange: Split VehicleNeedsService() into Vehicle::NeedsServicing() and Vehicle::NeedsAutomaticServicing(). draftTue, 08 Apr 2008 15:48:32 +0000, by frosch
-
(svn r12628) -Fix: TTDP compatible non-stop wasn't handled properly. draftTue, 08 Apr 2008 13:32:44 +0000, by rubidium
-
(svn r12624) -Codechange: Make drawing of catenary an attribute of rail types, instead of deciding by the rail type directly. draftTue, 08 Apr 2008 07:19:29 +0000, by peter1138
-
(svn r12622) -Fix: infinite loop in case your compiler decides that enums are unsigned by default. Patch by Dominik. draftMon, 07 Apr 2008 22:15:31 +0000, by rubidium
-
(svn r12620) -Fix: automatic servicing of vehicles made them stop in the depot. draftMon, 07 Apr 2008 21:02:27 +0000, by rubidium
-
(svn r12619) -Codechange: lots of documentation about window related stuff. Patch by Alberth. draftMon, 07 Apr 2008 20:28:58 +0000, by rubidium
-
(svn r12618) -Codechange: as load and unload type are now split, some case statements got ugly. draftMon, 07 Apr 2008 20:18:51 +0000, by rubidium
-
(svn r12617) -Codechange: add type safety to the Order's load and unload types. draftMon, 07 Apr 2008 20:03:46 +0000, by rubidium
-
(svn r12616) -Codechange: r12591 didn't work as expected for NDS, move one function back to cpp draftMon, 07 Apr 2008 20:02:36 +0000, by smatz
-
(svn r12615) -Codechange: rename some enums related to depot orders to make it more clear that they are no loading/unloading flags. Also add more type strictness. draftMon, 07 Apr 2008 19:18:56 +0000, by rubidium
-
(svn r12609) -Codechange: Remove wrong comments and give more comments on the drawing part of subsidies draftMon, 07 Apr 2008 17:02:39 +0000, by belugas
-
(svn r12608) -Fix [FS#1909]: pressing 'Load' did not cancel the full load order. draftMon, 07 Apr 2008 15:04:00 +0000, by rubidium
-
(svn r12605) -Cleanup: variable scope and coding style in train* draftMon, 07 Apr 2008 12:36:50 +0000, by smatz
-
(svn r12601) -Fix (r12587): do not reset the index of orders (causes loading ancient savegames to loop infinitively. draftMon, 07 Apr 2008 11:45:53 +0000, by rubidium
-
(svn r12600) -Codechange: make GetNonStopType return a more augmented type; not is there a non-stop order but the kind of non-stop order, so one doesn't need to check _patches.new_nonstop type everywhere. draftMon, 07 Apr 2008 08:59:04 +0000, by rubidium
-
(svn r12599) -Codechange: force AllocateSafeRaw() to be linked to simplify compiler's decisions about inlining draftSun, 06 Apr 2008 23:49:45 +0000, by smatz
-
(svn r12596) -Feature: show what cargos a station could be supplied with. Patch by Roujin. draftSun, 06 Apr 2008 22:32:20 +0000, by rubidium
-
(svn r12595) -Codechange: hide Order's flags in the last few cases. draftSun, 06 Apr 2008 21:54:22 +0000, by rubidium
-
(svn r12594) -Codechange: move large functions from driver.h to driver.cpp to reduce binary size and compile time draftSun, 06 Apr 2008 16:49:02 +0000, by smatz
-
(svn r12593) -Codechange: hide Order's flags in most of the code. draftSun, 06 Apr 2008 15:09:45 +0000, by rubidium
-
(svn r12592) -Fix (r12580): aircraft's go-to-depot handling is a mess, which assumes destination to be a station even when it did not set a destination yet. draftSun, 06 Apr 2008 14:50:47 +0000, by rubidium