Mercurial > hg > openttd
graph
-
(svn r16394) -Codechange: move (NewGRF) cache variables into a separate struct so (some vehicle related) NewGRF cache 'desyncs' can be tested easier. draftSat, 23 May 2009 09:10:56 +0000, by rubidium
-
(svn r16393) -Codechange: move VehicleRail to Train. draftFri, 22 May 2009 22:55:41 +0000, by rubidium
-
(svn r16392) -Codechange: move some variables (the ones that aren't caches) from VehicleRail to Train draftFri, 22 May 2009 22:33:05 +0000, by rubidium
-
(svn r16391) -Codechange: use Train instead of Vehicle where appropriate. draftFri, 22 May 2009 22:22:46 +0000, by rubidium
-
(svn r16390) -Codechange: move u.road to RoadVehicle. draftFri, 22 May 2009 20:22:20 +0000, by rubidium
-
(svn r16389) -Codechange: use RoadVehicle instead of Vehicle where appropriate draftFri, 22 May 2009 20:18:45 +0000, by rubidium
-
(svn r16387) -Codechange: use Aircraft instead of Vehicle where appropriate draftFri, 22 May 2009 20:03:26 +0000, by rubidium
-
(svn r16386) -Codechange: Move ShowAdditionalText() to build_vehicle_gui and make it static. draftFri, 22 May 2009 19:47:26 +0000, by frosch
-
(svn r16385) -Codechange: move u.disaster to DisasterVehicle. draftFri, 22 May 2009 18:57:11 +0000, by rubidium
-
(svn r16384) -Codechange: move u.effect to EffectVehicle draftFri, 22 May 2009 18:56:25 +0000, by rubidium
-
(svn r16383) -Fix/Change: Disable multitile houses with non-zero population on additional tiles as they cause desyncs and because the specs do not allow that either. draftFri, 22 May 2009 18:44:22 +0000, by frosch
-
(svn r16382) -Codechange: make GetVehicleTrackdir a member function of Vehicle. draftFri, 22 May 2009 18:17:20 +0000, by rubidium
-
(svn r16381) -Update: WebTranslator2 update to 2009-05-22 17:38:42 draftFri, 22 May 2009 17:38:53 +0000, by translators
-
(svn r16380) -Codechange: rename pool.hpp to pool_type.hpp draftFri, 22 May 2009 15:39:22 +0000, by smatz
-
(svn r16379) -Codechange: remove GetNumTowns(), GetNumIndustries() and GetActiveCompanyCount(), use PoolItem::GetNumItems() instead draftFri, 22 May 2009 15:23:47 +0000, by smatz
-
(svn r16378) -Codechange: replace OldPool with simpler Pool. Compilation time, binary size and run time (with asserts disabled) should be improved draftFri, 22 May 2009 15:13:50 +0000, by smatz
-
(svn r16377) -Codechange: unify FOR_ALL_* macros, use separate index variable instead of var->index draftFri, 22 May 2009 14:23:36 +0000, by smatz
-
(svn r16376) -Codechange: Vehicle::Tick() now returns false if the vehicle was deleted draftFri, 22 May 2009 13:53:14 +0000, by smatz
-
(svn r16375) -Codechange: don't be afraid of deleting NULL pointers draftFri, 22 May 2009 13:13:55 +0000, by smatz
-
(svn r16374) -Fix (r11622): Valid UTF-8 sequences between 0x20 and 0xFF should be allowed as is instead of being treated as control codes. draftFri, 22 May 2009 12:05:28 +0000, by peter1138
-
(svn r16373) -Codechange: use () instead of (void) for functions without parameters draftThu, 21 May 2009 22:43:25 +0000, by smatz
-
(svn r16372) -Codechange: Simplify size calculations with a few helper functions. draftThu, 21 May 2009 18:12:28 +0000, by alberth
-
(svn r16371) -Codechange (r16367): Properly align comments. draftThu, 21 May 2009 17:45:12 +0000, by alberth
-
(svn r16370) -Doc: Improvements to the nested widgets documentation, added explanation about computations, fixed typo in param description. draftThu, 21 May 2009 16:26:38 +0000, by alberth
-
(svn r16369) -Codechange: Renaming ComputeMinimalSize() to SetupSmallestSize(), and AssignMinimalPosition() to AssignSizePosition(), they do not compute minimal size anymore. draftThu, 21 May 2009 16:14:04 +0000, by alberth
-
(svn r16368) -Codechange: Only leaf widgets use min_x and min_y. draftThu, 21 May 2009 16:00:52 +0000, by alberth
-
(svn r16367) -Codechange: Do not use min_x and min_y for storing smallest size to allow initialization more than once. draftThu, 21 May 2009 15:48:27 +0000, by alberth
-
(svn r16366) -Fix: Use a valid StringID as fall-back when undefined generic newgrf strings of vehicles are requested. draftThu, 21 May 2009 13:05:48 +0000, by frosch
-
(svn r16363) -Fix: The previously selected newgrf station type was still remembered after switching to a different game without newstations enabled, preventing stations from being built. draftThu, 21 May 2009 07:29:50 +0000, by peter1138
-
(svn r16362) -Update: WebTranslator2 update to 2009-05-20 17:30:16 draftWed, 20 May 2009 17:30:30 +0000, by translators
-
(svn r16361) -Fix: pointer incremented with wrong count draftTue, 19 May 2009 21:25:20 +0000, by rubidium
-
(svn r16360) -Codechange: don't use _network_playas as a 'second' _local_company, but only as a storage location for the company you want to join in MP. draftTue, 19 May 2009 21:20:14 +0000, by rubidium
-
(svn r16359) -Codechange: don't abuse company 0 when determining 'cost to clear land' in the LandInfoWindow draftTue, 19 May 2009 19:26:03 +0000, by smatz
-
(svn r16357) -Codechange: delete invalid depots in TTD savegames caused by improper SVXConverter conversions draftTue, 19 May 2009 12:47:47 +0000, by smatz
-
(svn r16356) -Codechange: use 'size_t' instead of 'uint' as parameter of functions in mem_func.hpp draftTue, 19 May 2009 08:21:37 +0000, by smatz
-
(svn r16354) -Codechange: use 'new' pool accessors and methods for Engine too draftMon, 18 May 2009 19:32:16 +0000, by smatz
-
(svn r16353) -Fix (r1): invalid read when OTTD savegame contains VEH_INVALID draftMon, 18 May 2009 17:40:03 +0000, by smatz
-
(svn r16352) -Codechange: use PoolItem::GetIfValid() instead of PoolItem::IsValidID() and PoolItem::Get() draftMon, 18 May 2009 16:21:28 +0000, by smatz
-
(svn r16351) -Fix (r14773): signal handler could end in endless loop draftMon, 18 May 2009 12:01:13 +0000, by smatz
-
(svn r16350) -Codechange: make some 'rail track is present' checks more 'secure' draftMon, 18 May 2009 01:35:15 +0000, by smatz
-
(svn r16349) -Codechange: rename IsPlainRailTile() to IsPlainRail(), introduce shiny new IsPlainRailTile() draftMon, 18 May 2009 01:26:23 +0000, by smatz
-
(svn r16348) -Fix (r16280): buoys with invalid station ID could be left in the game draftMon, 18 May 2009 00:33:24 +0000, by smatz
-
(svn r16347) -Cleanup: remove some unused defines from oldpool.h. draftSun, 17 May 2009 20:38:22 +0000, by rubidium
-
(svn r16346) -Codechange: don't exploit the pool system in the way done for the saveload pool; it makes writing replacements unnecessarily difficult. And now we've got SmallVector that does more than enough for saving with less lines of 'interface' code. draftSun, 17 May 2009 20:38:05 +0000, by rubidium
-
(svn r16345) -Codechange: replace the Sound(Entry) pool with a simple vector of SoundEntries. draftSun, 17 May 2009 19:36:28 +0000, by rubidium
-
(svn r16344) -Codechange: s/FileEntry/SoundEntry/ draftSun, 17 May 2009 19:27:50 +0000, by rubidium
-
(svn r16343) -Fix (r16066): Invalid free on exit after changing base graphics set in game. draftSun, 17 May 2009 19:14:22 +0000, by frosch
-
(svn r16342) -Feature(tte): Display base graphics description in game options window. draftSun, 17 May 2009 18:21:21 +0000, by frosch
-
(svn r16341) -Codechange: just use a static array instead of a never freed malloc draftSun, 17 May 2009 17:48:05 +0000, by rubidium
-
(svn r16340) -Codechange: introduce SoundID (uint16) and use that instead of SoundFX, which was used as a byte and uint16 at different places, when the uint16 sound ID is meant. draftSun, 17 May 2009 17:17:48 +0000, by rubidium
-
(svn r16339) -Fix: [NewGRF] When overriding 'original sounds', only allow overriding of the 'original sounds' and not any other that is already loaded. draftSun, 17 May 2009 17:00:30 +0000, by rubidium
-
(svn r16338) -Codechange: split loading of references to two phases draftSun, 17 May 2009 16:28:29 +0000, by smatz
-
(svn r16336) -Codechange: make the SpriteGroup pool more like the 'normal' pools draftSun, 17 May 2009 14:32:13 +0000, by rubidium
-
(svn r16335) -Codechange: indenting fixes in saveload.cpp draftSun, 17 May 2009 11:47:56 +0000, by smatz
-
(svn r16333) -Cleanup: remove a bunch of unused wrapper functions. draftSun, 17 May 2009 11:18:34 +0000, by rubidium
-
(svn r16332) -Codechange: replace some -1 + 1 with 'nothing' or <= .. - 1 with < .. - 1 (both caused due to wrapper functions) draftSun, 17 May 2009 11:17:53 +0000, by rubidium