Mercurial > hg > openttd
graph
-
(svn r17852) -Codechange: Use viewport nested widget in the view-vehicle window. draftSat, 24 Oct 2009 13:58:18 +0000, by alberth
-
(svn r17851) -Codechange: Use pure nested widgets for the view-vehicle window. draftSat, 24 Oct 2009 13:49:04 +0000, by alberth
-
(svn r17850) -Codechange: remove most usage of delta on OnResize draftSat, 24 Oct 2009 09:47:02 +0000, by rubidium
-
(svn r17849) -Codechange: make the saveload windows nested draftFri, 23 Oct 2009 21:10:36 +0000, by rubidium
-
(svn r17848) -Codechange: allow overriding (some) settings of STACKED_SELECTION_ZERO_SIZE widgets via UpdateWidgetSize draftFri, 23 Oct 2009 21:10:24 +0000, by rubidium
-
(svn r17846) -Codechange: make the network content window nested draftThu, 22 Oct 2009 16:45:29 +0000, by rubidium
-
(svn r17845) -Fix (r17744): Missing 'g' in sed command. draftThu, 22 Oct 2009 16:01:28 +0000, by frosch
-
(svn r17844) -Fix (r17790): typo in the documentation draftThu, 22 Oct 2009 15:20:38 +0000, by rubidium
-
(svn r17843) -Codechange: move the details drawing code of the content window to a separate function draftThu, 22 Oct 2009 14:26:18 +0000, by rubidium
-
(svn r17842) -Fix: DrawStringMultiLine would in some corner case, top = bottom + 1, draw the string draftThu, 22 Oct 2009 14:24:11 +0000, by rubidium
-
(svn r17841) -Codechange: move state changes from OnPaint to OnInvalidate for the content gui. draftThu, 22 Oct 2009 13:57:39 +0000, by rubidium
-
(svn r17840) -Codechange: use the new pool's concepts (caching + not zeroing). Improves average CargoPacket con/destruction time by ~20%, MoveTo/Append by 5-10% and application performance by up to 2%. draftWed, 21 Oct 2009 19:42:49 +0000, by rubidium
-
(svn r17839) -Codechange: implement the concept of 'caching' pool items to pools, that is instead of 'free' push the unused items in a linked list and use them on 'malloc'. Also add the concept of zeroing, or actually not zeroing, on new for pool items. draftWed, 21 Oct 2009 19:38:50 +0000, by rubidium
-
(svn r17838) -Document: the Pool struct's template parameters draftWed, 21 Oct 2009 15:40:50 +0000, by rubidium
-
(svn r17837) -Fix (r17812): comment erroneously mentioned feeder share draftWed, 21 Oct 2009 10:05:22 +0000, by rubidium
-
(svn r17834) -Fix [FS#3274] (r17808): you got paid a bit too much... ofcourse the index of the source station generally doesn't equal the location of said station. draftTue, 20 Oct 2009 22:06:33 +0000, by rubidium
-
(svn r17833) -Codechange: Depot gui should use relative widget coordinates for clicking. draftTue, 20 Oct 2009 21:41:44 +0000, by alberth
-
(svn r17831) -Codechange: move code used for adding map indicators of the smallmap to separate functions draftTue, 20 Oct 2009 21:26:56 +0000, by smatz
-
(svn r17829) -Codechange: move code used for adding vehicles and town names to minimap to separate functions draftTue, 20 Oct 2009 20:57:30 +0000, by smatz
-
(svn r17828) -Codechange: Variable declaration code style, and a few comment typo-ish fixes. draftTue, 20 Oct 2009 20:06:25 +0000, by alberth
-
(svn r17827) -Codechange: Deduplicate some lines of code. draftTue, 20 Oct 2009 20:01:56 +0000, by frosch
-
(svn r17826) -Codechange: GetRoadVehLength() is only used in one file, make it static. draftTue, 20 Oct 2009 19:55:09 +0000, by frosch
-
(svn r17825) -Change: 'animate' the 'center to current position' button in SmallMapWindow when pressed draftTue, 20 Oct 2009 19:38:51 +0000, by smatz
-
(svn r17824) -Fix (r4594): _date_fract runs from 0 to 73 since r2041. Variable 0x09 should not. draftTue, 20 Oct 2009 19:30:50 +0000, by frosch
-
(svn r17823) -Codechange: Use top of the matrix widget as offset for row calculation in autoreplace window. draftTue, 20 Oct 2009 18:39:45 +0000, by alberth
-
(svn r17822) -Codechange: move 'extra viewport' code from smallmap_gui.cpp to viewport_gui.cpp draftTue, 20 Oct 2009 18:38:38 +0000, by smatz
-
(svn r17821) -Codechange: make more mathods of SmallMapWindow private draftTue, 20 Oct 2009 18:15:42 +0000, by smatz
-
(svn r17819) -Codechange: replace magic constant by symbolic constant draftTue, 20 Oct 2009 17:36:06 +0000, by smatz
-
(svn r17818) -Codechange: iterate the cargo list from the back when trying to merge packets. Chances are higher that the last packet (in the FIFO-ish queue) is mergeable with the to be added package. If a train gets loaded packets get split up and put into the different carriages, at unload they are unloaded in the same order so the last in the FIFO-ish queue is likely the packet it can merge with. draftTue, 20 Oct 2009 16:36:35 +0000, by rubidium
-
(svn r17817) -Codechange: MakeWater actually made sea tiles, so rename it to MakeSea and unduplicate the code to make sea, rivers and canals. draftTue, 20 Oct 2009 12:31:11 +0000, by rubidium
-
(svn r17816) -Codechange: move the CargoList invalidation-after-saveload to the function that handles the CargoPackets instead of spreading it around over the saveload files. Also add some code to validate whether the caches are valid; to be removed later when no problems turn up draftTue, 20 Oct 2009 12:20:53 +0000, by rubidium
-
(svn r17815) -Fix [SDL]: asynchronious drawing caused extra unresponsiveness during map generation; disable the threading while generating a map draftMon, 19 Oct 2009 20:32:05 +0000, by rubidium
-
(svn r17814) -Codechange: there's no need to invalidate the cache in the constructor of a CargoList; the list is empty, the CargoList is calloc-ed so all caches are 0. draftMon, 19 Oct 2009 15:36:35 +0000, by rubidium
-
(svn r17813) -Codechange: unify the CargoPacket related coding style draftMon, 19 Oct 2009 09:15:47 +0000, by rubidium
-
(svn r17812) -Codechange: move the feeder_share cache from CargoList to VehicleCargoList; saves 512 bytes per station and 1-2% on CargoList::MoveTo. draftMon, 19 Oct 2009 01:12:51 +0000, by rubidium
-
(svn r17810) -Codechange/Fix: Add assert_tcompile() and use it. draftSun, 18 Oct 2009 20:26:29 +0000, by frosch
-
(svn r17808) -Codechange: remove write 'access' from all of CargoPacket's variables draftSun, 18 Oct 2009 17:53:34 +0000, by rubidium
-
(svn r17807) -Codechange: move all 'updates' just after the 'load' constructor of CargoPackets to the constructor call itself draftSun, 18 Oct 2009 17:52:44 +0000, by rubidium
-
(svn r17806) -Codechange: split CargoPacket's 'afterload' to a separate function draftSun, 18 Oct 2009 17:47:38 +0000, by rubidium
-
(svn r17804) -Codechange: move the CargoPacket 'invalidation' when stations get removed to CargoPacket. draftSun, 18 Oct 2009 17:26:10 +0000, by rubidium
-
(svn r17803) -Codechange: Remove update_(left|right) in favour of the rebuild flag of GUIList. draftSun, 18 Oct 2009 16:31:27 +0000, by frosch
-
(svn r17802) -Feature(ette) [FS#1862]: [NewGRF] Textstack support for CB 37. draftSun, 18 Oct 2009 15:36:30 +0000, by frosch
-
(svn r17801) -Codechange: for StationCargoLists the 'loaded_at_xy' does not matter when merging CargoPackets draftSun, 18 Oct 2009 14:30:37 +0000, by rubidium
-
(svn r17800) -Codechange: first steps into making CargoList a template draftSun, 18 Oct 2009 14:28:26 +0000, by rubidium
-
(svn r17799) -Codechange: industry view window uses pure nested widgets. draftSun, 18 Oct 2009 14:10:59 +0000, by alberth
-
(svn r17798) -Codechange: Introduce new constant WD_PAR_VSEP_WIDE for large amount of space between text. draftSun, 18 Oct 2009 13:59:25 +0000, by alberth
-
(svn r17797) -Codechange: Use parameters of new function, introduce constants for hardcoded numbers. draftSun, 18 Oct 2009 13:56:09 +0000, by alberth
-
(svn r17796) -Codechange: Move drawing of the industry info to its own function. draftSun, 18 Oct 2009 13:40:11 +0000, by alberth
-
(svn r17795) -Codechange: split cargolist into one for vehicles and one for stations. draftSun, 18 Oct 2009 13:39:00 +0000, by rubidium
-
(svn r17794) -Feature: [OSX] Implement automatic fallback font selection for OSX. draftSat, 17 Oct 2009 22:36:43 +0000, by michi_cc
-
(svn r17793) -Fix: [OSX] The splash image wasn't displayed if the Quartz video driver was used. draftSat, 17 Oct 2009 22:36:39 +0000, by michi_cc