Mercurial > hg > openttd
graph
-
(svn r3856) Distinct between bridge ramps and bridge middle parts draftTue, 14 Mar 2006 09:00:10 +0000, by tron
-
(svn r3854) - Fix restart_game_date to default to zero and allow a value of 0 which got screwed up during the patch-rewrite. Thanks peter1138 draftMon, 13 Mar 2006 23:20:24 +0000, by Darkvater
-
(svn r3853) - Fix a change of SetDParam64 to SetDParam in r3713 that caused slightly vibrating text when pressing the cheat-button. Thanks to peter1138 for noticing. draftMon, 13 Mar 2006 23:13:21 +0000, by Darkvater
-
(svn r3852) - Revert r3733 which fixed the default value loading for char, but broke loading a set value. Added a better fix which needs a char value to be a string (eg enclosed in double-quotes) draftMon, 13 Mar 2006 23:10:02 +0000, by Darkvater
-
(svn r3851) Rail depots only have an entrance at one side, therefore use UpdateSignalsOnSegment() instead of SetSignalsOnBothDir() draftMon, 13 Mar 2006 20:12:35 +0000, by tron
-
(svn r3846) Add functions to set the type of stuff (clear, water, rail, road) under bridges draftMon, 13 Mar 2006 12:55:20 +0000, by tron
-
(svn r3838) Demystify building bridge middle parts a bit by removing some magic numbers and generic names draftMon, 13 Mar 2006 07:12:49 +0000, by tron
-
(svn r3837) Partially unmagicfy restoring the tiles when deleting a bridge draftSun, 12 Mar 2006 20:59:56 +0000, by tron
-
(svn r3832) Replace some magic numbers by (Diag)Direction enums draftSun, 12 Mar 2006 17:42:04 +0000, by tron
-
(svn r3830) Move IsTunnelTile() from tile.h to tunnel_map.h and add IsTunnel(), which just checks for a tunnel, but not the tile type as IsTunnelTile() does draftSun, 12 Mar 2006 15:04:03 +0000, by tron
-
(svn r3829) Reduce the use of _error_message by directly returning error codes instead of using this global variable draftSun, 12 Mar 2006 12:19:25 +0000, by tron
-
(svn r3827) Remove the global variable _error_message_2, it's only used as local variable draftSun, 12 Mar 2006 10:15:36 +0000, by tron
-
(svn r3823) Remove dead code: A value for 'image' gets calculated and overwritten just a few lines later without being used in between draftSun, 12 Mar 2006 08:47:18 +0000, by tron
-
(svn r3820) Be a bit more strict with types: use special types instead of generic byte and don't fill arbitrary data into inappropriate types draftSat, 11 Mar 2006 17:06:16 +0000, by tron
-
(svn r3814) Remove another call to FindLandscapeHeight() draftFri, 10 Mar 2006 17:01:51 +0000, by tron
-
(svn r3811) -Fix: [autoreplace]: (FS#67) autoreplacing trains now keep their tile length instead of their pixel length draftFri, 10 Mar 2006 10:01:56 +0000, by bjarni
-
(svn r3809) - Add map accessor files to MS VS 2003 project file draftFri, 10 Mar 2006 09:20:28 +0000, by peter1138
-
(svn r3805) - [FS#62] Fix doxygen comments to refer to the correct parameter. (sulai) draftThu, 09 Mar 2006 20:37:51 +0000, by peter1138
-
(svn r3803) Change the second parameter of UpdateSignalsOnSegment() from Direction to DiagDirection as that's what it really operates on draftThu, 09 Mar 2006 12:32:25 +0000, by tron
-
(svn r3802) * Add a dummy file in the scenario dir to make the makefile stop complaining on make install (temporary hack). draftWed, 08 Mar 2006 23:21:32 +0000, by matthijs
-
(svn r3801) * Update debian packaging files to the ones used for releasing 0.4.5 (see os/debian/changelog for details). draftWed, 08 Mar 2006 23:12:38 +0000, by matthijs
-
(svn r3796) When unmagicfying code, do it Right(tm) and also give the variables sensible names. I flipped a 'b' and a 'd' in r3785 draftWed, 08 Mar 2006 19:47:18 +0000, by tron
-
(svn r3795) Add a function to request the orientation of a depot draftWed, 08 Mar 2006 15:29:23 +0000, by tron
-
(svn r3794) Use already available accessor functions instead of GB() draftWed, 08 Mar 2006 15:28:38 +0000, by tron
-
(svn r3792) -Fix: Mark the right tile as dirty. It's just a graphical glitch which happend in r1592 draftWed, 08 Mar 2006 13:03:29 +0000, by tron
-
(svn r3791) Replace home grown direction handling for placing lighthouses by standard DiagDir draftWed, 08 Mar 2006 12:26:56 +0000, by tron
-
(svn r3789) Add an enum and function to handle DiagDirection changes draftWed, 08 Mar 2006 08:51:26 +0000, by tron
-
(svn r3785) Replace some if-magic to determine the turning direction for road vehicles with the new DirDiff stuff draftWed, 08 Mar 2006 07:50:26 +0000, by tron
-
(svn r3784) Add a type and functions to handle direction changes draftWed, 08 Mar 2006 07:48:56 +0000, by tron
-
(svn r3783) Replace further ints and magic numbers by Direction, DiagDirection and friends draftWed, 08 Mar 2006 06:55:33 +0000, by tron
-
(svn r3779) Move CheckTunnelInWay() to a more appropriate place, invert its result and give it a less ambiguous name (IsTunnelInWay) draftTue, 07 Mar 2006 07:51:05 +0000, by tron
-
(svn r3778) - Fix crash when resizing news history window. draftMon, 06 Mar 2006 23:01:35 +0000, by peter1138
-
(svn r3776) Replace many ints and magic numbers by Direction, DiagDirection and friends draftMon, 06 Mar 2006 20:28:28 +0000, by tron
-
(svn r3775) Fix loading of server_port from config file, introduced in Darkvater's unified configuration changes (r3719+) draftMon, 06 Mar 2006 19:23:26 +0000, by peter1138
-
(svn r3773) Shove some semantics down ottd's throat by replacing ints and magic numbers by enums and some related changes draftMon, 06 Mar 2006 13:11:08 +0000, by tron
-
(svn r3770) Remove the _road_special_gettrackstatus hack. Egladil and me deem it unnecessary draftSun, 05 Mar 2006 17:24:04 +0000, by tron
-
(svn r3769) Add a cast to make KUDr's C++ compiler happy draftSun, 05 Mar 2006 12:54:22 +0000, by tron
-
(svn r3767) Move all direction related enums and functions to a separate header draftSun, 05 Mar 2006 12:34:55 +0000, by tron
-
(svn r3766) Add a function to get the RoadBits from an arbitrary tile draftSun, 05 Mar 2006 12:22:20 +0000, by tron
-
(svn r3765) Fix some naming glitches in r3763 and add missing svn properties draftSun, 05 Mar 2006 11:18:34 +0000, by tron
-
(svn r3763) Adapt to the new 'map accessors go in foo_map.h'-scheme draftSun, 05 Mar 2006 10:19:33 +0000, by tron
-
(svn r3760) Replace some magic numbers for checking for a suitable slope for a level crossing by some less magic numbers. Quite similar to r3699, though this time for placing the rails draftSat, 04 Mar 2006 13:52:52 +0000, by tron
-
(svn r3758) Remove the news validation callback. It is superseded by r3757. draftSat, 04 Mar 2006 11:15:44 +0000, by tron
-
(svn r3757) -Feature: Delete news items about vehicles, when they get stale draftSat, 04 Mar 2006 11:01:35 +0000, by tron
-
(svn r3754) Miscellaneous changes: indentation, reduce variable scope, constness, avoid some more function pointer casts draftFri, 03 Mar 2006 22:21:29 +0000, by tron
-
(svn r3751) -Fix: Correctly implement minimum search, so road vehicles head twoards the closest station, not the last one in the list draftFri, 03 Mar 2006 21:18:19 +0000, by tron