Mercurial > hg > openttd
graph
-
(svn r17876) -Codechange: make the network company password window nested draftMon, 26 Oct 2009 12:24:14 +0000, by rubidium
-
(svn r17875) -Change [FS#3272]: prefer extmidi over allegro midi and allegro over null driver draftSun, 25 Oct 2009 21:47:32 +0000, by smatz
-
(svn r17874) -Codechange: vehicle details window uses pure nested widgets. draftSun, 25 Oct 2009 21:42:04 +0000, by alberth
-
(svn r17873) -Codechange: make the advanced settings window nested draftSun, 25 Oct 2009 21:18:12 +0000, by rubidium
-
(svn r17872) -Codechange: apply coding style to splash.cpp draftSun, 25 Oct 2009 17:55:13 +0000, by smatz
-
(svn r17871) -Fix (r11342): memset() accepts only 1-byte argument draftSun, 25 Oct 2009 17:36:24 +0000, by smatz
-
(svn r17870) -Codechange: Use fontsize when drawing roadveh, ship, and aircraft details. draftSun, 25 Oct 2009 17:21:57 +0000, by alberth
-
(svn r17869) -Codechange: don't create OnScroll() event for zero delta draftSun, 25 Oct 2009 17:01:45 +0000, by smatz
-
(svn r17868) -Codechange: Vehicle list window uses nested widgets only. draftSun, 25 Oct 2009 15:08:16 +0000, by alberth
-
(svn r17867) -Codechange: Prepare BaseVehicleListWindow for nested widgets. draftSun, 25 Oct 2009 14:52:46 +0000, by alberth
-
(svn r17866) -Codechange: make the remaining graph windows nested draftSun, 25 Oct 2009 13:52:58 +0000, by rubidium
-
(svn r17865) -Codechange: Remove references to specific widgets and step-heights from BaseVehicleListWindow::DrawVehicleListItems(). draftSun, 25 Oct 2009 13:33:56 +0000, by alberth
-
(svn r17863) -Codechange: make the build vehicle window nested draftSun, 25 Oct 2009 00:26:40 +0000, by rubidium
-
(svn r17862) -Codechange: Use edge positions of the matrix widget in DrawVehicleRefitWindow. draftSat, 24 Oct 2009 21:10:57 +0000, by alberth
-
(svn r17861) -Fix (r17860): max(uint, int) does not exist. draftSat, 24 Oct 2009 20:28:54 +0000, by alberth
-
(svn r17860) -Codechange: Refit window uses pure nested widgets. draftSat, 24 Oct 2009 20:26:18 +0000, by alberth
-
(svn r17859) -Codechange: make the fund/build/prospect industry window nested draftSat, 24 Oct 2009 19:36:24 +0000, by rubidium
-
(svn r17857) -Fix (r10442): [NewGRF] 'subtract-in' is also signed for production callback version 0. draftSat, 24 Oct 2009 18:51:21 +0000, by frosch
-
(svn r17856) -Codechange: Don't get the selected cargo as a sife effect of drawing. draftSat, 24 Oct 2009 18:37:23 +0000, by alberth
-
(svn r17855) -Codechange: Remove or move var declarations in DrawVehicleRefitWindow(). draftSat, 24 Oct 2009 18:27:21 +0000, by alberth
-
(svn r17854) -Codechange: Merge different cases of setting widget data together in the view vehicle window. draftSat, 24 Oct 2009 15:19:06 +0000, by alberth
-
(svn r17852) -Codechange: Use viewport nested widget in the view-vehicle window. draftSat, 24 Oct 2009 13:58:18 +0000, by alberth
-
(svn r17851) -Codechange: Use pure nested widgets for the view-vehicle window. draftSat, 24 Oct 2009 13:49:04 +0000, by alberth
-
(svn r17850) -Codechange: remove most usage of delta on OnResize draftSat, 24 Oct 2009 09:47:02 +0000, by rubidium
-
(svn r17849) -Codechange: make the saveload windows nested draftFri, 23 Oct 2009 21:10:36 +0000, by rubidium
-
(svn r17848) -Codechange: allow overriding (some) settings of STACKED_SELECTION_ZERO_SIZE widgets via UpdateWidgetSize draftFri, 23 Oct 2009 21:10:24 +0000, by rubidium
-
(svn r17846) -Codechange: make the network content window nested draftThu, 22 Oct 2009 16:45:29 +0000, by rubidium
-
(svn r17845) -Fix (r17744): Missing 'g' in sed command. draftThu, 22 Oct 2009 16:01:28 +0000, by frosch
-
(svn r17844) -Fix (r17790): typo in the documentation draftThu, 22 Oct 2009 15:20:38 +0000, by rubidium
-
(svn r17843) -Codechange: move the details drawing code of the content window to a separate function draftThu, 22 Oct 2009 14:26:18 +0000, by rubidium
-
(svn r17842) -Fix: DrawStringMultiLine would in some corner case, top = bottom + 1, draw the string draftThu, 22 Oct 2009 14:24:11 +0000, by rubidium
-
(svn r17841) -Codechange: move state changes from OnPaint to OnInvalidate for the content gui. draftThu, 22 Oct 2009 13:57:39 +0000, by rubidium
-
(svn r17840) -Codechange: use the new pool's concepts (caching + not zeroing). Improves average CargoPacket con/destruction time by ~20%, MoveTo/Append by 5-10% and application performance by up to 2%. draftWed, 21 Oct 2009 19:42:49 +0000, by rubidium
-
(svn r17839) -Codechange: implement the concept of 'caching' pool items to pools, that is instead of 'free' push the unused items in a linked list and use them on 'malloc'. Also add the concept of zeroing, or actually not zeroing, on new for pool items. draftWed, 21 Oct 2009 19:38:50 +0000, by rubidium
-
(svn r17838) -Document: the Pool struct's template parameters draftWed, 21 Oct 2009 15:40:50 +0000, by rubidium
-
(svn r17837) -Fix (r17812): comment erroneously mentioned feeder share draftWed, 21 Oct 2009 10:05:22 +0000, by rubidium
-
(svn r17834) -Fix [FS#3274] (r17808): you got paid a bit too much... ofcourse the index of the source station generally doesn't equal the location of said station. draftTue, 20 Oct 2009 22:06:33 +0000, by rubidium
-
(svn r17833) -Codechange: Depot gui should use relative widget coordinates for clicking. draftTue, 20 Oct 2009 21:41:44 +0000, by alberth
-
(svn r17831) -Codechange: move code used for adding map indicators of the smallmap to separate functions draftTue, 20 Oct 2009 21:26:56 +0000, by smatz
-
(svn r17829) -Codechange: move code used for adding vehicles and town names to minimap to separate functions draftTue, 20 Oct 2009 20:57:30 +0000, by smatz
-
(svn r17828) -Codechange: Variable declaration code style, and a few comment typo-ish fixes. draftTue, 20 Oct 2009 20:06:25 +0000, by alberth
-
(svn r17827) -Codechange: Deduplicate some lines of code. draftTue, 20 Oct 2009 20:01:56 +0000, by frosch
-
(svn r17826) -Codechange: GetRoadVehLength() is only used in one file, make it static. draftTue, 20 Oct 2009 19:55:09 +0000, by frosch
-
(svn r17825) -Change: 'animate' the 'center to current position' button in SmallMapWindow when pressed draftTue, 20 Oct 2009 19:38:51 +0000, by smatz
-
(svn r17824) -Fix (r4594): _date_fract runs from 0 to 73 since r2041. Variable 0x09 should not. draftTue, 20 Oct 2009 19:30:50 +0000, by frosch
-
(svn r17823) -Codechange: Use top of the matrix widget as offset for row calculation in autoreplace window. draftTue, 20 Oct 2009 18:39:45 +0000, by alberth
-
(svn r17822) -Codechange: move 'extra viewport' code from smallmap_gui.cpp to viewport_gui.cpp draftTue, 20 Oct 2009 18:38:38 +0000, by smatz
-
(svn r17821) -Codechange: make more mathods of SmallMapWindow private draftTue, 20 Oct 2009 18:15:42 +0000, by smatz
-
(svn r17819) -Codechange: replace magic constant by symbolic constant draftTue, 20 Oct 2009 17:36:06 +0000, by smatz
-
(svn r17818) -Codechange: iterate the cargo list from the back when trying to merge packets. Chances are higher that the last packet (in the FIFO-ish queue) is mergeable with the to be added package. If a train gets loaded packets get split up and put into the different carriages, at unload they are unloaded in the same order so the last in the FIFO-ish queue is likely the packet it can merge with. draftTue, 20 Oct 2009 16:36:35 +0000, by rubidium
-
(svn r17817) -Codechange: MakeWater actually made sea tiles, so rename it to MakeSea and unduplicate the code to make sea, rivers and canals. draftTue, 20 Oct 2009 12:31:11 +0000, by rubidium