Mercurial > hg > openttd
graph
-
(svn r18045) -Fix: GCC 4.5@HEAD not compiling OpenTTD anymore because of a "non-placement deallocation function [is] selected for placement delete", or in other words delete(void *, size_t) is 'magic'. draftWed, 11 Nov 2009 21:15:58 +0000, by rubidium
-
(svn r18044) -Change: mention (one of the) bug report(s) for the known-but-will-not-or-cannot-fix bugs and order them by FS ID draftWed, 11 Nov 2009 21:09:04 +0000, by rubidium
-
(svn r18043) -Document: the resizing issue with SDL and OpenTTD draftWed, 11 Nov 2009 21:07:12 +0000, by rubidium
-
(svn r18042) -Cleanup: remove some stale comments draftWed, 11 Nov 2009 20:53:23 +0000, by rubidium
-
(svn r18040) -Codechange: the size parameter (if it's that actually) isn't needed for the delete operator draftWed, 11 Nov 2009 20:40:40 +0000, by rubidium
-
(svn r18038) -Fix [FS#3290] (r17402): AIs failed to load their data from savegames by crashing them when they tried draftWed, 11 Nov 2009 18:13:17 +0000, by rubidium
-
(svn r18035) -Fix (r16909): one could remotely crash (assert) the server on certain commands draftTue, 10 Nov 2009 11:19:07 +0000, by rubidium
-
(svn r18033) -Codechange: make the padding for IMGBTN_2 the same as for IMGBTN; the image doesn't move, so the extra space at the right and bottom aren't needed draftMon, 09 Nov 2009 17:20:48 +0000, by rubidium
-
(svn r18030) -Fix: screen jumped a bit for at least SDL and Allegro when right-click-dragging draftMon, 09 Nov 2009 16:05:24 +0000, by rubidium
-
(svn r18029) -Fix (r18028): AppendPathSeparator() should stay global draftMon, 09 Nov 2009 15:16:38 +0000, by glx
-
(svn r18028) -Codechange: unglobalise some functions draftMon, 09 Nov 2009 10:40:33 +0000, by rubidium
-
(svn r18027) -Codechange: make some unneededly global variables static and remove some unused variables draftMon, 09 Nov 2009 09:59:35 +0000, by rubidium
-
(svn r18026) -Codechange: make a lookup table static that doesn't need to be 'exported' draftMon, 09 Nov 2009 09:27:48 +0000, by rubidium
-
(svn r18025) -Fix (r17217): more missing/extra parentheses (for compilers I've never heard of) draftSun, 08 Nov 2009 23:56:39 +0000, by rubidium
-
(svn r18023) -Codechange: Make the timetable window nested. draftSun, 08 Nov 2009 20:52:14 +0000, by alberth
-
(svn r18022) -Cleanup: remove some (now) unused button resize functions draftSun, 08 Nov 2009 19:49:13 +0000, by rubidium
-
(svn r18021) -Codechange: Have a widget for every cargo-type to eliminate searching. draftSun, 08 Nov 2009 19:36:17 +0000, by alberth
-
(svn r18020) -Codechange: Make the company station list window nested. draftSun, 08 Nov 2009 19:31:57 +0000, by alberth
-
(svn r18019) -Codechange: make the 'engine preview' window nested draftSun, 08 Nov 2009 19:22:45 +0000, by rubidium
-
(svn r18018) -Codechange: make the 'buy company' window nested draftSun, 08 Nov 2009 19:21:18 +0000, by rubidium
-
(svn r18016) -Codechange: Move the arbitrary basecost multiplier offset (8) to newgrf loading and make the internal state zero-based instead. draftSun, 08 Nov 2009 18:04:53 +0000, by frosch
-
(svn r18015) -Codechange: redesign the world generation windows to make 'proper' use of nested widgets. draftSun, 08 Nov 2009 16:46:23 +0000, by rubidium
-
(svn r18014) -Codechange: Station view window uses pure nested widgets. draftSun, 08 Nov 2009 15:26:20 +0000, by alberth
-
(svn r18013) -Codechange: Add possibility to change window size during ReInit(). draftSun, 08 Nov 2009 15:22:04 +0000, by alberth
-
(svn r18012) -Codechange: make the world generation windows nested; they'll need some tweaks to use the full potential though draftSun, 08 Nov 2009 13:35:45 +0000, by rubidium
-
(svn r18011) -Feature(ette): [NewGRF] CB 36 for roadvehicle property 09 'running cost factor'. draftSun, 08 Nov 2009 13:02:05 +0000, by frosch
-
(svn r18010) -Codechange: Split StationViewWindow::OnPaint in four functions. draftSun, 08 Nov 2009 12:45:16 +0000, by alberth
-
(svn r18009) -Codechange: make the 'create scenario' window nested draftSun, 08 Nov 2009 12:38:00 +0000, by rubidium
-
(svn r18008) -Codechange: Rename NUM_PRICES to PR_END, and use the Price enum some more. draftSun, 08 Nov 2009 12:23:02 +0000, by frosch
-
(svn r18007) -Codechange: No need to call CB 36 'running cost factor' if the vehicle has no running cost class anyway. draftSun, 08 Nov 2009 12:18:59 +0000, by frosch
-
(svn r18006) -Codechange: make the world generation progress window nested draftSun, 08 Nov 2009 12:11:38 +0000, by rubidium
-
(svn r18005) -Codechange: Convert the Prices struct into an array and an enum. draftSat, 07 Nov 2009 22:47:54 +0000, by frosch
-
(svn r18003) -Cleanup: prune some unused functions from Window draftSat, 07 Nov 2009 22:29:17 +0000, by rubidium
-
(svn r18002) -Change: add cases to Greek and use them (fumantsu) draftSat, 07 Nov 2009 21:51:21 +0000, by rubidium
-
(svn r18001) -Codechange: [SDL] When the mouse cursor is locked into position when scrolling a viewport, warp the mouse pointer to the centre of the window. This gives maximum freedom of movement. The pointer position is restored when the lock is removed. Visually the mouse cursor stays where it was. draftSat, 07 Nov 2009 21:41:41 +0000, by peter1138
-
(svn r17999) -Fix: [NewGRF] Improve parsing of RIFF data. Skip unknown chunks and check chunk sizes. draftSat, 07 Nov 2009 18:22:00 +0000, by frosch
-
(svn r17998) -Fix (r17994): Use a consistent item list width. draftSat, 07 Nov 2009 17:45:49 +0000, by alberth
-
(svn r17997) -Codechange: Introduce functions for querying top and bottom of the main view. draftSat, 07 Nov 2009 17:24:04 +0000, by alberth
-
(svn r17995) -Codechange: PreventHiding() is used in one file, make it static. draftSat, 07 Nov 2009 15:49:36 +0000, by alberth
-
(svn r17994) -Codechange: Make the dropdown menu window use pure nested widgets. draftSat, 07 Nov 2009 14:40:37 +0000, by alberth
-
(svn r17993) -Codechange: Move widget and data initialization into the dropdown menu class. draftSat, 07 Nov 2009 11:44:38 +0000, by alberth
-
(svn r17992) -Codechange: Merge some parameters of the dropdown menu. draftSat, 07 Nov 2009 11:26:23 +0000, by alberth
-
(svn r17991) -Codechange: Use WD_VSCROLLBAR_WIDTH constant in dropdown menu window. draftSat, 07 Nov 2009 10:26:09 +0000, by alberth
-
(svn r17990) -Codechange: Add widgets enum for dropdown menu window. draftSat, 07 Nov 2009 08:41:34 +0000, by alberth
-
(svn r17986) -Codechange: make the scenario 'main' toolbar nested. Also make it implement the 'switch' toolbar feature when it gets really small. draftFri, 06 Nov 2009 20:34:43 +0000, by rubidium
-
(svn r17985) -Codechange: make the toolbar container support non-resizable widgets and subclassing of itself. draftFri, 06 Nov 2009 20:32:15 +0000, by rubidium
-
(svn r17984) -Codechange: make it possible to use MakeNWidgets using a custom container widget. draftFri, 06 Nov 2009 20:26:28 +0000, by rubidium
-
(svn r17977) -Fix: Busses and trucks are distinguished by cargo class. draftThu, 05 Nov 2009 20:26:13 +0000, by frosch