Mercurial > hg > openttd
graph
-
(svn r19499) -Remove: same_industry_close setting did not do what it said and caused NewGRF trouble. draftSun, 21 Mar 2010 15:16:05 +0000, by frosch
-
(svn r19498) -Feature [FS#3710]: Keep number padding intact when cloning vehicle names. draftSun, 21 Mar 2010 11:35:41 +0000, by peter1138
-
(svn r19497) -Fix: [NewGRF] Bytes and words get sign-extended for temporary/persistent storage. (Spotted by yexo) draftSun, 21 Mar 2010 11:05:39 +0000, by frosch
-
(svn r19493) -Codechange: Keep track of last error in CmdDepotSellAllVehicles(). draftSat, 20 Mar 2010 17:22:15 +0000, by alberth
-
(svn r19492) -Codechange: Keep track of last error in CmdClearArea(). draftSat, 20 Mar 2010 17:19:16 +0000, by alberth
-
(svn r19491) -Codechange: Keep track of last error in CmdRemoveLongRoad(). draftSat, 20 Mar 2010 17:14:26 +0000, by alberth
-
(svn r19490) -Fix: Return to old behaviour of CmdLevelLand() by keeping track of last error. draftSat, 20 Mar 2010 17:13:00 +0000, by alberth
-
(svn r19489) -Codechange: Introduce a had_success variable in SendAllVehiclesToDepot(). draftSat, 20 Mar 2010 17:10:14 +0000, by alberth
-
(svn r19488) -Codechange: Use last_error data for removal in CmdRailTrackHelper() as well. draftSat, 20 Mar 2010 17:08:16 +0000, by alberth
-
(svn r19487) -Codechange: Removed non-reachable return statement. draftSat, 20 Mar 2010 16:53:46 +0000, by alberth
-
(svn r19486) -Codechange: Code style, move var declarations closer to their first use. draftSat, 20 Mar 2010 16:47:07 +0000, by alberth
-
(svn r19485) -Codechange: Re-implement CalcBridgeLenCostFactor() in a more readable way without changing computed costs. draftSat, 20 Mar 2010 16:45:23 +0000, by alberth
-
(svn r19484) -Codechange: Rename parameter 'x' of CalcBridgeLenCostFactor() to 'length'. draftSat, 20 Mar 2010 15:32:58 +0000, by alberth
-
(svn r19483) -Codechange: Code layout fixes, and parentheses reduction. draftSat, 20 Mar 2010 15:30:57 +0000, by alberth
-
(svn r19481) -Codechange: Turn _industry_counts into a static member of Industry. draftSat, 20 Mar 2010 14:30:16 +0000, by frosch
-
(svn r19480) -Fix: Stop reducing the size of the vehicle list after selecting a vehicle with a long description. draftSat, 20 Mar 2010 12:21:01 +0000, by terkhen
-
(svn r19479) -Codechange: Test range of town size and layout instead of against the current last value. draftSat, 20 Mar 2010 10:59:06 +0000, by alberth
-
(svn r19478) -Codechange: Resolve TS_ prefix clash between TileSource and TownSize enums. draftSat, 20 Mar 2010 10:55:08 +0000, by alberth
-
(svn r19477) -Fix (r1946x): removed a few too functions including the copy constructor draftFri, 19 Mar 2010 22:46:22 +0000, by yexo
-
(svn r19476) -Codechange: simplify the 'is conflicting industry nearby' check a bit draftFri, 19 Mar 2010 21:23:54 +0000, by yexo
-
(svn r19475) -Cleanup: Remove an unneeded for when drawing detail panels. draftFri, 19 Mar 2010 21:00:15 +0000, by terkhen
-
(svn r19474) -Cleanup: remove ByteBlob::Append(T*, num_items) draftFri, 19 Mar 2010 20:44:23 +0000, by yexo
-
(svn r19473) -Codechange: remove unused variables in the Blob::SmartAlloc code (skidd13) draftFri, 19 Mar 2010 20:28:28 +0000, by yexo
-
(svn r19472) -Codechange: reorder the static members of ByteBlob and add Zero() (skidd13) draftFri, 19 Mar 2010 20:13:15 +0000, by yexo
-
(svn r19471) -Codechange: rename ByteBlob methods to fit common style (skidd13) draftFri, 19 Mar 2010 20:08:40 +0000, by yexo
-
(svn r19470) -Codechange: rename blob internals (skidd13) draftFri, 19 Mar 2010 20:06:33 +0000, by yexo
-
(svn r19469) -Codechange: remove unused functions from Blob (skidd13) draftFri, 19 Mar 2010 20:05:49 +0000, by yexo
-
(svn r19468) -Codechange: make ptr_u union in Blob anonymous (skidd13) draftFri, 19 Mar 2010 20:04:24 +0000, by yexo
-
(svn r19467) -Codechange: Use uint and byte direct instead of declaring internal types (skidd13) draftFri, 19 Mar 2010 20:03:25 +0000, by yexo
-
(svn r19465) -Codechange: support for multi-tile hangars draftFri, 19 Mar 2010 11:17:52 +0000, by yexo
-
(svn r19464) -Codechange: move GetHangarTile to Airport draftFri, 19 Mar 2010 09:58:46 +0000, by yexo
-
(svn r19463) -Codechange: add helper function to determine if an airport has at least one hangar draftFri, 19 Mar 2010 09:48:44 +0000, by yexo
-
(svn r19462) -Codechange: use the AS_GENERIC macro also for the dummy airport draftFri, 19 Mar 2010 00:34:38 +0000, by yexo
-
(svn r19461) -Fix (r19355): p1 was still used in two places draftThu, 18 Mar 2010 23:41:39 +0000, by yexo
-
(svn r19460) -Fix [FS#3703]: [NPF] Crash when finding a waypoint before finding the closest depot draftThu, 18 Mar 2010 23:27:11 +0000, by rubidium
-
(svn r19459) -Feature: make some airport properties modifyable by newgrfs draftThu, 18 Mar 2010 23:15:38 +0000, by yexo
-
(svn r19457) -Codechange: introduce AirportOverrideManager to keep track of airports if a newgrf can't be found draftThu, 18 Mar 2010 23:12:38 +0000, by yexo
-
(svn r19456) -Codechange; increase the maximum number of airports draftThu, 18 Mar 2010 23:10:35 +0000, by yexo
-
(svn r19455) -Codechange: split all airport information in Station to a seperate class draftThu, 18 Mar 2010 21:02:20 +0000, by yexo
-
(svn r19453) -Codechange: split getting the initial aircraft position to a new function draftThu, 18 Mar 2010 18:38:32 +0000, by yexo
-
(svn r19452) -Change: plural type of Slovak (keso) draftThu, 18 Mar 2010 16:34:50 +0000, by rubidium
-
(svn r19450) -Fix (r19197): animation callbacks for airport tiles where never called draftThu, 18 Mar 2010 15:20:21 +0000, by yexo
-
(svn r19449) -Codechange: pay for every airport tile build, not for every tile in the rectangle where the airport is build draftThu, 18 Mar 2010 00:41:16 +0000, by yexo
-
(svn r19445) -Change: No need to drag an area when overbuilding bridges. draftWed, 17 Mar 2010 20:19:55 +0000, by frosch
-
(svn r19444) -Update: base set translations for Polish, Slovak and Turkish. draftWed, 17 Mar 2010 19:15:31 +0000, by rubidium
-
(svn r19443) -Fix [FS#3701]: Mark industry windows dirty more often. draftWed, 17 Mar 2010 18:52:56 +0000, by frosch
-
(svn r19442) -Update: readme about openmsx and make it easier to find the pulseaudio-ubuntu-slowness bug in the readme/known-bugs draftWed, 17 Mar 2010 18:50:41 +0000, by rubidium
-
(svn r19441) -Fix (r19437): broken Greek translation. draftWed, 17 Mar 2010 18:49:59 +0000, by rubidium
-
(svn r19438) -Fix [FS#3700]: Custom group names are misaligned with default ones when using rtl languages (sbr) draftTue, 16 Mar 2010 20:15:38 +0000, by rubidium