Mercurial > hg > openttd
graph
-
(svn r21604) -Add: Variable 7B for accessing 60+x variables while taking the parameter from the accumulator. draftWed, 22 Dec 2010 22:03:57 +0000, by frosch
-
(svn r21603) -Codechange: no need to assign something to a variable and then test it for NULL when you're never using it again draftWed, 22 Dec 2010 21:19:39 +0000, by rubidium
-
(svn r21602) -Codechange: split actual adding/removing of orders to/from a vehicle's order list from the validation of those (user) commands. Based on patch by fonsinchen draftWed, 22 Dec 2010 21:16:34 +0000, by rubidium
-
(svn r21601) -Fix [FS#4323]: company league table used stats from two quarters ago instead of last quarter draftWed, 22 Dec 2010 19:52:23 +0000, by rubidium
-
(svn r21600) -Codechange: Remove new_drawstyle and new_diagonal variables from the _thd structure. draftWed, 22 Dec 2010 19:24:36 +0000, by alberth
-
(svn r21597) -Fix (r21239): Also catch the case when callback 10 returns VE_DEFAULT. draftWed, 22 Dec 2010 14:51:12 +0000, by frosch
-
(svn r21596) -Codechange: Rename a misleading-named variable. draftWed, 22 Dec 2010 14:38:24 +0000, by frosch
-
(svn r21595) -Codechange: Some header files had their name changed, update the ifndef/define/endif lines. draftWed, 22 Dec 2010 11:46:41 +0000, by alberth
-
(svn r21594) -Codechange: Whitespace fixes in ifndef/define lines. draftWed, 22 Dec 2010 11:24:38 +0000, by alberth
-
(svn r21593) -Codechange: endif comment correcttions. draftWed, 22 Dec 2010 10:50:32 +0000, by alberth
-
(svn r21592) -Codechange: Return unique values for placing a sign and land-info querying, store the callback information locally, and use it instead of the global _place_proc. draftTue, 21 Dec 2010 22:00:08 +0000, by alberth
-
(svn r21590) -Codechange: All click handling functions of the main toolbar return CBF_NONE. draftTue, 21 Dec 2010 21:48:31 +0000, by alberth
-
(svn r21589) -Codechange: Move PlaceLandBlockInfo() to the right file, introduce a ShowLandInfo() function. draftTue, 21 Dec 2010 21:46:19 +0000, by alberth
-
(svn r21587) -Codechange: Move simple callback functions into the switch. draftTue, 21 Dec 2010 18:07:07 +0000, by alberth
-
(svn r21586) -Codechange: Record the last started user action, and use that in the callback. draftTue, 21 Dec 2010 18:06:23 +0000, by alberth
-
(svn r21585) -Codechange: Move the simple click functions into the switch. draftTue, 21 Dec 2010 18:05:24 +0000, by alberth
-
(svn r21584) -Codechange: Replace the _rail_build_button array by a switch. draftTue, 21 Dec 2010 18:04:10 +0000, by alberth
-
(svn r21583) -Fix (r21566): The new scrollbar was not ignored correctly for ships and aircrafts. draftTue, 21 Dec 2010 17:29:00 +0000, by terkhen
-
(svn r21582) -Codechange: Simplify BuildRailClick_AutoSignals(). draftTue, 21 Dec 2010 16:36:00 +0000, by alberth
-
(svn r21581) -Codechange: Fix indenting code style of a few multi-line statements. draftTue, 21 Dec 2010 16:30:54 +0000, by alberth
-
(svn r21580) -Codechange: Replace callback via pointer by a switch statement. draftTue, 21 Dec 2010 16:27:50 +0000, by alberth
-
(svn r21579) -Codechange: Remove _build_air_button_proc and its functions to a switch statement, record the last started action. draftTue, 21 Dec 2010 16:26:34 +0000, by alberth
-
(svn r21578) -Fix [FS#2585]: [OSX] A double mouse cursor was shown under certain circumstances (based on patch by matheweis) draftTue, 21 Dec 2010 16:05:25 +0000, by planetmaker
-
(svn r21577) -Codechange: [OSX] Deduplicate code by moving the handling of the window class for screen drivers to a common class draftTue, 21 Dec 2010 16:02:55 +0000, by planetmaker
-
(svn r21576) -Codechange: [OSX] Deduplicate code by moving the handling of the view for windowed screen drivers to a common class draftTue, 21 Dec 2010 16:00:42 +0000, by planetmaker
-
(svn r21575) -Codechange: [OSX] Use the same class for the window delegate routines in windowed screen drivers draftTue, 21 Dec 2010 15:57:55 +0000, by planetmaker
-
(svn r21574) -Codechange: [OSX] Move the variable declaration of the screen drivers to the generic class, deduplicating code draftTue, 21 Dec 2010 15:56:02 +0000, by planetmaker
-
(svn r21573) -Codechange: [OSX] Unify the naming of variables among different screen drivers a bit draftTue, 21 Dec 2010 15:53:20 +0000, by planetmaker
-
(svn r21572) -Codechange: [OSX] One palette is enough, we cannot use two colour depths at once draftTue, 21 Dec 2010 15:48:43 +0000, by planetmaker
-
(svn r21571) -Codechange: Having a break after a return is no good. draftTue, 21 Dec 2010 15:23:54 +0000, by alberth
-
(svn r21570) -Add: Allow to select a vehicle and the following chain with a keyboard shortcut. draftTue, 21 Dec 2010 14:01:44 +0000, by terkhen
-
(svn r21569) -Add: Don't close the refit window after refitting only a consist part. draftTue, 21 Dec 2010 14:00:58 +0000, by terkhen
-
(svn r21568) -Add: Show the selected consist part at the refit window. draftTue, 21 Dec 2010 14:00:14 +0000, by terkhen
-
(svn r21567) -Feature: Allow to refit only the selected part of a train consist. draftTue, 21 Dec 2010 13:59:16 +0000, by terkhen
-
(svn r21566) -Add: Draw current vehicle at the refit window. draftTue, 21 Dec 2010 13:58:09 +0000, by terkhen
-
(svn r21565) -Codechange: Add pixel skip to DrawRoadVehImage(). draftTue, 21 Dec 2010 13:56:52 +0000, by terkhen
-
(svn r21564) -Fix: Avoid drawing road vehicles outside of their given space. draftTue, 21 Dec 2010 13:56:07 +0000, by terkhen
-
(svn r21563) -Codechange: Add function to get the width of a vehicle. draftTue, 21 Dec 2010 13:54:57 +0000, by terkhen
-
(svn r21562) -Change: Add articulated parts of vehicles in a refit selection to that selection. draftTue, 21 Dec 2010 13:53:19 +0000, by terkhen
-
(svn r21561) -Change: Allow to specify the number of vehicles to refit in the refit vehicle command. draftTue, 21 Dec 2010 13:52:10 +0000, by terkhen
-
(svn r21560) -Codechange: Declare DrawVehicleImage in its header. draftTue, 21 Dec 2010 13:50:31 +0000, by terkhen
-
(svn r21559) -Add: Disable the refit button until a refit option is selected. draftTue, 21 Dec 2010 13:49:42 +0000, by terkhen
-
(svn r21558) -Codechange: add the graphics set and its version to the screenshot metadata as well draftTue, 21 Dec 2010 10:11:11 +0000, by rubidium
-
(svn r21557) -Change: close the query windows when changing the language as often the strings are partly translated, which causes trouble in some cases draftTue, 21 Dec 2010 10:06:21 +0000, by rubidium
-
(svn r21556) -Fix [FS#4320]: argt wasn't updated when argv was updated due to ARG_INDEX, so there was a mismatch between argt's offset and argv's offset causing trouble when getting the gender of a string draftTue, 21 Dec 2010 10:04:40 +0000, by rubidium
-
(svn r21555) -Fix [FS#4321]: strings for the query window weren't properly terminated to N characters anymore draftTue, 21 Dec 2010 09:29:01 +0000, by rubidium
-
(svn r21553) -Feature-ish: store the used OpenTTD version, NewGRFs and AIs in the screenshot file draftMon, 20 Dec 2010 22:54:15 +0000, by rubidium
-
(svn r21552) -Codechange: Move short callback functions into the switch. draftMon, 20 Dec 2010 19:24:27 +0000, by alberth
-
(svn r21551) -Codechange: Record the last started user action, and use that in the callback. draftMon, 20 Dec 2010 19:23:07 +0000, by alberth
-
(svn r21550) -Codechange: Move the small static functions into the switch. draftMon, 20 Dec 2010 19:21:50 +0000, by alberth
-
(svn r21549) -Codechange: Unfold the _build_road_button_proc array into a switch. draftMon, 20 Dec 2010 19:20:38 +0000, by alberth
-
(svn r21548) -Codechange: Code style, multi line statements should indent two tabs. draftMon, 20 Dec 2010 19:19:23 +0000, by alberth
-
(svn r21547) -Add [FS#4318]: Tooltip describing the the behaviour of the shift key for several actions draftMon, 20 Dec 2010 19:17:24 +0000, by planetmaker
-
(svn r21545) -Codechange: Replace the callback by another switch. draftMon, 20 Dec 2010 13:19:59 +0000, by alberth
-
(svn r21544) -Codechange: Fold the small static click functions into the switch. draftMon, 20 Dec 2010 13:17:54 +0000, by alberth