Mercurial > hg > openttd
graph
-
(svn r20462) -Fix (r20452): Initialise scrollbar_index with -1 to indicate 'no scrollbar associated'. draftThu, 12 Aug 2010 09:47:48 +0000, by frosch
-
(svn r20461) -Codechange: Replace WWT_HSCROLLBAR, WWT_SCROLLBAR and WWT_SCROLL2BAR with NWID_HSCROLLBAR and NWID_VSCROLLBAR. draftThu, 12 Aug 2010 09:16:43 +0000, by frosch
-
(svn r20460) -Codechange: Remove WF_SCROLL window flags and store the state directly in the scrollbar widget instead. draftThu, 12 Aug 2010 09:14:34 +0000, by frosch
-
(svn r20459) -Codechange: Remove the Scrollbar members of Window and make NWidgetScrollbar inherit from Scrollbar instead. draftThu, 12 Aug 2010 09:13:04 +0000, by frosch
-
(svn r20458) -Codechange: Move Scrollbar from window.cpp to widget.cpp draftThu, 12 Aug 2010 09:11:12 +0000, by frosch
-
(svn r20457) -Codechange: Remove _scrolling_scrollbar and WF_SCROLL_MIDDLE and instead store the widget index of the being scrolled scrollbar in the Window. draftThu, 12 Aug 2010 09:09:24 +0000, by frosch
-
(svn r20456) -Codechange: Add separate nested widget class for scrollbars. draftThu, 12 Aug 2010 09:07:45 +0000, by frosch
-
(svn r20455) -Codechange: Rename some vscroll and vscroll2 to more suitable names. draftThu, 12 Aug 2010 08:42:37 +0000, by frosch
-
(svn r20453) -Codechange: Remove direct accesses to Window::hscroll, vscroll and vscroll2. draftThu, 12 Aug 2010 08:37:01 +0000, by frosch
-
(svn r20452) -Codechange: Remove NWidgetCore::FindScrollbar() and associate scrollbar explicitly using a NWidgetPart via SetScrollbar(). draftThu, 12 Aug 2010 06:44:45 +0000, by frosch
-
(svn r20451) -Codechange: Add helper function Window::GetScrollbar() to get the Scrollbar belonging to a scrollbar widget. draftThu, 12 Aug 2010 06:40:28 +0000, by frosch
-
(svn r20450) -Fix: same the airport tile ID mapping as well draftWed, 11 Aug 2010 19:09:26 +0000, by rubidium
-
(svn r20449) -Codechange: unduplicate saving/loading of NewGRF ID + local id -> OpenTTD spec mappings draftWed, 11 Aug 2010 18:57:48 +0000, by rubidium
-
(svn r20448) -Codechange: make some functions that can be const const draftWed, 11 Aug 2010 18:50:23 +0000, by rubidium
-
(svn r20446) -Codechange: unify the location of the water class draftWed, 11 Aug 2010 14:14:06 +0000, by rubidium
-
(svn r20445) -Codechange (r20435): Some compilers (esp. mine) do not comply to the specs. draftWed, 11 Aug 2010 07:42:47 +0000, by frosch
-
(svn r20444) -Cleanup: unify writing of {NUM} x {NUM} draftTue, 10 Aug 2010 23:32:09 +0000, by rubidium
-
(svn r20443) -Codechange: more TileHash to a more generic location draftTue, 10 Aug 2010 23:31:43 +0000, by rubidium
-
(svn r20441) -Fix [FS#4024]: adding "goto nearest depot and stop" orders in one go was denied. This caused both AI adding those orders and backed up order restoration to fail. draftTue, 10 Aug 2010 16:45:32 +0000, by rubidium
-
(svn r20440) -Fix: MSVC warning about shifting a 32 bit value and then converting it to 64 bits draftTue, 10 Aug 2010 16:17:51 +0000, by rubidium
-
(svn r20439) -Fix [FS#4023]: MinGW compiler complaining about converting -1 to an unsigned int draftTue, 10 Aug 2010 16:15:42 +0000, by rubidium
-
(svn r20437) -Codechange: lets Engines use GRFFilePropsBase as well draftTue, 10 Aug 2010 15:54:53 +0000, by rubidium
-
(svn r20436) -Codechange: use GRFFilePropsBase's spritegroup for stations. draftTue, 10 Aug 2010 15:51:33 +0000, by rubidium
-
(svn r20435) -Codechange: move spritegroup to GRFFilePropsBase and prepare it for more spritegroups draftTue, 10 Aug 2010 15:49:35 +0000, by rubidium
-
(svn r20427) -Revert (r20105): even though MCI has less problems with wrongly pitched songs than dmusic, it crashed instead. draftMon, 09 Aug 2010 18:29:13 +0000, by rubidium
-
(svn r20426) -Update: the known bugs (part by Eddi|zuHause) draftMon, 09 Aug 2010 18:16:16 +0000, by rubidium
-
(svn r20424) -Fix: Rename members of TileContext (TC_NORMAL conflicted with an existing define on MinGW). draftMon, 09 Aug 2010 10:59:30 +0000, by terkhen
-
(svn r20423) -Change [FS#3947]: Make snow on bridges depend on bridgeheight. draftMon, 09 Aug 2010 07:32:04 +0000, by frosch
-
(svn r20422) -Change [FS#3947]: Resolve tracksprites on bridges always using the southern bridgehead as tile. draftMon, 09 Aug 2010 07:30:50 +0000, by frosch
-
(svn r20421) -Change [FS#3947]: Make snowyness of bridgehead depend on the tileheight at the entry edge. draftMon, 09 Aug 2010 07:19:44 +0000, by frosch
-
(svn r20420) -Codechange: Add TileContext enum instead of using a bool. draftMon, 09 Aug 2010 07:10:42 +0000, by frosch
-
(svn r20419) -Codechange: Rename dummy_land.cpp to void_cmd.cpp draftMon, 09 Aug 2010 06:48:52 +0000, by frosch
-
(svn r20418) -Fix [FS#4017](r20125): During world generation the snow-mapbits are not yet available, so test the snowline variable directly (as before). draftSun, 08 Aug 2010 21:34:19 +0000, by frosch
-
(svn r20417) -Fix (r20345) [FS#4018]: the offset stored for objects shouldn't be substracted immediately from the TileIndex as that doesn't quite do the right thing draftSun, 08 Aug 2010 19:50:07 +0000, by rubidium
-
(svn r20415) -Add: Clicking at the smallmap disables updates from the industry chain window. draftSun, 08 Aug 2010 11:21:24 +0000, by alberth
-
(svn r20414) -Feature: Enable industries in the smallmap displayed in the industry chain window. draftSun, 08 Aug 2010 11:17:14 +0000, by alberth
-
(svn r20413) -Fix (r20326): some comments got a bit outdated draftSun, 08 Aug 2010 11:12:34 +0000, by rubidium
-
(svn r20412) -Codechange: Replace an if by a switch in IndustryCargoesWindow::OnClick. draftSun, 08 Aug 2010 11:02:57 +0000, by alberth
-
(svn r20411) -Codechange: rename unmovables as quite a lot of them are actually movable; e.g. HQ and owned land are pretty movable. draftSun, 08 Aug 2010 10:59:30 +0000, by rubidium
-
(svn r20410) -Codechange: Move smallmap map-type switching to a function. draftSun, 08 Aug 2010 10:47:09 +0000, by alberth
-
(svn r20409) -Codechange: reduce the number of includes needed by newgrf.h draftSun, 08 Aug 2010 09:07:40 +0000, by rubidium
-
(svn r20408) -Fix [FS#4013]: PBS reservations were always displayed on halftile foundations if the railtype uses overlays. draftSun, 08 Aug 2010 08:52:47 +0000, by frosch
-
(svn r20407) -Codechange: make AirportClass use the new generic class draftSat, 07 Aug 2010 22:08:20 +0000, by rubidium
-
(svn r20406) -Codechange: make StationClass use the new generic class draftSat, 07 Aug 2010 22:07:07 +0000, by rubidium
-
(svn r20405) -Add: generic class for "classes" for NewGRFs, e.g. the Station classes and Airport classes draftSat, 07 Aug 2010 22:05:58 +0000, by rubidium
-
(svn r20404) -Codechange: remove the need for StationSpec::allocated draftSat, 07 Aug 2010 21:39:30 +0000, by rubidium
-
(svn r20403) -Fix (r20399): forgot to update regression draftSat, 07 Aug 2010 21:32:39 +0000, by yexo
-
(svn r20402) -Codechange: rename the airport/station class id to something slightly more generic draftSat, 07 Aug 2010 21:10:57 +0000, by rubidium
-
(svn r20401) -Codechange: let HouseSpec use GRFFileProps draftSat, 07 Aug 2010 21:03:38 +0000, by rubidium
-
(svn r20400) -Codechange: let StationSpec use GRFFilePropsBase draftSat, 07 Aug 2010 20:52:45 +0000, by rubidium
-
(svn r20399) -Change: [NoAI] AIIndustry::IsCargoAccepted now returns 3 possible values so AIs can detect a temporaral refusal from an industry to accept some cargo type draftSat, 07 Aug 2010 20:51:53 +0000, by yexo
-
(svn r20398) -Codechange: move some variables of GRFFileProps into (the new) GRFFilePropsBase draftSat, 07 Aug 2010 20:51:07 +0000, by rubidium
-
(svn r20397) -Feature: Display industry smallmap colour in the industry chain window. draftSat, 07 Aug 2010 20:36:23 +0000, by alberth
-
(svn r20396) -Codechange: introduce a helper function to test whether an industry temporarily refues to accept some cargo draftSat, 07 Aug 2010 20:11:27 +0000, by yexo