Mercurial > hg > openttd
graph
-
(svn r4203) - Fix compilation on mingw32 (stdint.h not included) draftFri, 31 Mar 2006 15:34:22 +0000, by orudge
-
(svn r4201) - Codechange: Do for _engine_info[] what we do for _*_vehicle_info[]; create and use a function to retrieve data, and ensure constness. draftFri, 31 Mar 2006 12:59:43 +0000, by peter1138
-
(svn r4200) -Codechange: Make use of water map accessors when getting the Index of a Ship Depot. TODO: Store the depot index in the map draftFri, 31 Mar 2006 10:47:06 +0000, by celestar
-
(svn r4199) - Codechange: Use industry map accessors to get industry graphics type. draftFri, 31 Mar 2006 10:44:32 +0000, by peter1138
-
(svn r4198) - NewGRF: Rename GetCallBackResult() to GetVehicleCallback(), as other types will exist later, and use separate parameters instead of bitshifting. draftFri, 31 Mar 2006 10:14:25 +0000, by peter1138
-
(svn r4197) reentered STATIC_ZLIB_PATH (removed in 4183) since it turned out that it's used after all draftFri, 31 Mar 2006 10:04:18 +0000, by bjarni
-
(svn r4196) -Codechange: Add and make use of an accessor that modifies the size of the Company HQ draftFri, 31 Mar 2006 09:09:26 +0000, by celestar
-
(svn r4195) - Codechange: Initialize order variables to avoid a compiler warning. These are unused anyway... (smells of r3476-7, but not the same) draftFri, 31 Mar 2006 09:08:02 +0000, by peter1138
-
(svn r4193) -Codechange: Add and make use of an accessor function to create company HQs draftFri, 31 Mar 2006 08:44:53 +0000, by celestar
-
(svn r4192) - Fix: In the depot, moving wagons from the end of a very long train to a short train where the short train was scrolled off the window would cause a game crash. (Thanks to SimonRC for reporting.) draftFri, 31 Mar 2006 08:39:10 +0000, by peter1138
-
(svn r4191) - Codechange: Properly set newlines and id for os_timer.c draftFri, 31 Mar 2006 08:35:05 +0000, by Darkvater
-
(svn r4190) -Codechange: Add and make use of an accessor function to create houses draftFri, 31 Mar 2006 08:18:14 +0000, by celestar
-
(svn r4187) Simplify the code for building/removing a piece of road a bit draftFri, 31 Mar 2006 06:16:04 +0000, by tron
-
(svn r4183) -Codechange: [Makefile]: removed MANUAL_CONFIG as it's not used anymore draftThu, 30 Mar 2006 20:14:06 +0000, by bjarni
-
(svn r4181) CodeChange : Replaced [G/S]etMapExtraBits by [G/S]etTropicZone. Although it was an accessor, nor his usage nor the values were clear. draftThu, 30 Mar 2006 19:16:44 +0000, by belugas
-
(svn r4180) -Fix: Fixed an assert in the elrail drawing code due to passing of a wrong variable. I wish the compiler would warn about different enum types used... draftThu, 30 Mar 2006 15:47:18 +0000, by celestar
-
(svn r4179) -Codechange: Add and make use of an accessor that obtains the building type draftThu, 30 Mar 2006 15:06:49 +0000, by celestar
-
(svn r4178) -Fix: Draw catenary inside waypoints as well draftThu, 30 Mar 2006 13:12:36 +0000, by celestar
-
(svn r4177) -Fix: GetRailTrackBitsUniversal needs Trackbits, not Track. While at it, remove an unused variable draftThu, 30 Mar 2006 13:06:16 +0000, by celestar
-
(svn r4173) -Codechange: Use IsClearWaterTile for buoy construction draftThu, 30 Mar 2006 12:00:35 +0000, by celestar
-
(svn r4172) -Codechange: Added a few accessors to work with ShipDepots and Locks draftThu, 30 Mar 2006 11:21:36 +0000, by celestar
-
(svn r4171) -Codechange: Create map accessor functions for creating ship depots and locks. Make use of them draftThu, 30 Mar 2006 11:11:35 +0000, by celestar
-
(svn r4169) -Codechange: Removed an include which accidently slipped into a commit draftThu, 30 Mar 2006 11:05:05 +0000, by celestar
-
(svn r4168) -Fix: Fixed a typo in previous commit draftThu, 30 Mar 2006 10:53:31 +0000, by celestar
-
(svn r4166) Sprinkle several map accessors with assert()s draftThu, 30 Mar 2006 09:29:01 +0000, by tron
-
(svn r4165) -Do not use GetBridgeAxis on bridge ramps (request by Tron) draftThu, 30 Mar 2006 09:26:17 +0000, by celestar
-
(svn r4163) CodeChange : Add missing file to MS Project and Workspace files draftThu, 30 Mar 2006 00:48:45 +0000, by belugas
-
(svn r4160) CodeChange : Revert part of 4157, spotted by Tron draftWed, 29 Mar 2006 21:10:42 +0000, by belugas
-
(svn r4159) added missing comments about refitting in CmdCloneVehicle draftWed, 29 Mar 2006 20:57:17 +0000, by bjarni
-
(svn r4158) -Fix: [autoreplace] cost for refitting the new vehicle is now added to the cost animation. The player always paid for it, but it was not displayed until now draftWed, 29 Mar 2006 20:41:15 +0000, by bjarni
-
(svn r4157) CodeChange : Keep on cleaning up Celestar's elrail merge draftWed, 29 Mar 2006 20:35:39 +0000, by belugas
-
(svn r4156) CodeChange : Little cleanup after Celestar's elrail merge draftWed, 29 Mar 2006 20:06:31 +0000, by belugas
-
(svn r4155) -Changed GetRoadStopByTile to use GetStationType and moved it. TODO: unify RS_TRUCK and STATION_TRUCK (same for bus) draftWed, 29 Mar 2006 19:37:18 +0000, by celestar
-
(svn r4154) -Moved MAX_BRIDGES in bridge.h and made it an enum. This makes two drops ... draftWed, 29 Mar 2006 19:03:47 +0000, by celestar
-
(svn r4153) -Codechange. Changed NPF_TILE_LENGTH into an enum and moved it out of variables.h. Just a drop in the bucket, but it is a start draftWed, 29 Mar 2006 19:00:56 +0000, by celestar
-
(svn r4151) -Fix: [PowerPC] removed an incorrect uninitialized var used warning in os_timer draftWed, 29 Mar 2006 16:56:38 +0000, by bjarni
-
(svn r4150) -Feature: Merged elrails into trunk. Thanks to Tron for lots of code and proofreading, thanks to peter1138 for another lot of code and ideas. draftWed, 29 Mar 2006 16:30:26 +0000, by celestar
-
(svn r4149) -Codechange: [OSX] rewrite of how universal binaries are compiled draftWed, 29 Mar 2006 16:28:41 +0000, by bjarni
-
(svn r4143) -[FS#86]: Fixed and obi-wan error in station_map.h that would lead to assertions in the airport handling (of international airports) draftWed, 29 Mar 2006 06:51:13 +0000, by celestar
-
(svn r4142) - Fix [FS#74]: Incorrectly loaded settings from the config file when the signed uint32 variable would be negative. draftTue, 28 Mar 2006 21:51:14 +0000, by Darkvater
-
(svn r4136) CodeChange : Revert part of r4092 (as spotted by Tron) and clean-up a little further draftMon, 27 Mar 2006 14:28:56 +0000, by belugas
-
(svn r4134) Revert part of r4133: Replacing a byte which gets written to savegames by an enum is a very bad idea draftMon, 27 Mar 2006 06:18:02 +0000, by tron
-
(svn r4133) - Some miscellaneous changes (unconverted TownID in function definition, Owner instead of byte, remove obsolete member and compare waypoint index with 0 not STR_NULL) draftSun, 26 Mar 2006 22:58:11 +0000, by Darkvater
-
(svn r4131) - CodeChange: Add proper semantics for StationID for such variables instead of using the general uint16-type. StationID was added for depots, waypoints and stations where necessary. We probably need to change GetDepot(), IsDepotIndex(), IsStationIndex(), GetWaypoint() and IsWaypointIndex() as well to use StationID. draftSun, 26 Mar 2006 22:55:27 +0000, by Darkvater
-
(svn r4130) - CodeChange: Add proper semantics for TownID for such variables instead of using the general uint16-type. We probably need to change GetTown() and IsTownIndex() as well to use TownID. draftSun, 26 Mar 2006 22:41:56 +0000, by Darkvater
-
(svn r4129) - CodeChange: Add proper bool type for is_ai as well...it is a bool type. draftSun, 26 Mar 2006 22:25:29 +0000, by Darkvater
-
(svn r4128) - CodeChange: Add proper semantics for CargoID for such variables instead of using the general byte-type. draftSun, 26 Mar 2006 22:23:32 +0000, by Darkvater
-
(svn r4127) - Update English language file to use tags for the new unit system. draftSun, 26 Mar 2006 22:02:11 +0000, by peter1138
-
(svn r4126) - Feature: A new multi-lingual multi-measuring-unit system: draftSun, 26 Mar 2006 21:50:57 +0000, by peter1138
-
(svn r4124) - CodeChange: remove windows-specific code from initializing the random generator. There was no need for it. draftSun, 26 Mar 2006 21:13:16 +0000, by Darkvater
-
(svn r4123) - Forward-port the release-changes from the 0.4 branch back to trunk. This ensures an updated changelog, known-bugs, etc. draftSun, 26 Mar 2006 21:07:56 +0000, by Darkvater
-
(svn r4120) Use the new station functions where appropriate draftSun, 26 Mar 2006 19:20:15 +0000, by tron
-
(svn r4119) There's one more possible hangar tile. Check for this in IsHangar(), too draftSun, 26 Mar 2006 19:03:03 +0000, by tron
-
(svn r4116) -Fix: The AI should send a plane into a hangar if it's not in a hangar _or_ not stopped, not when it's not in a hangar _and_ not stopped draftSun, 26 Mar 2006 18:48:23 +0000, by tron