diff configure.ac @ 15291:7ae14907ae43

build: Add tests for specific Qt functions to configure.ac * configure.ac: Add OCTAVE_CHECK_FUNC_FINDFIRST_MODERN and OCTAVE_CHECK_FUNC_SETPLACEHOLDERTEXT macro calls * m4/acinclude.m4 (OCTAVE_CHECK_FUNC_SETPLACEHOLDERTEXT): Check whether Qt has SetPlaceholderText function. * (OCTAVE_CHECK_FUNC_FINDFIRST_MODERN): Check whether Qscintilla FindFirst accepts 16 or 17 input arguments. * find-dialog.cc, webinfo.cc: check configure HAVE_XXX values before using possibly unsupported functions.
author Rik <rik@octave.org>
date Tue, 04 Sep 2012 15:54:12 -0700 (2012-09-04)
parents d048ef58bb72
children 637e3b7d6a56
line wrap: on
line diff
--- a/configure.ac
+++ b/configure.ac
@@ -2203,6 +2203,10 @@
     fi
   fi
 
+  ## Check for Qt functions which have changed their API over time
+  OCTAVE_CHECK_FUNC_FINDFIRST_MODERN
+  OCTAVE_CHECK_FUNC_SETPLACEHOLDERTEXT
+
   case "$canonical_host_type" in
     *-*-mingw* | *-*-msdosmsvc*) win32_terminal=yes ;;
     *)