diff doc/interpreter/Makefile.am @ 9968:f3bef90b7278

Remove various install-local targets in favor of using automake syntax for installation
author Rik <rdrider0-list@yahoo.com>
date Fri, 11 Dec 2009 11:21:06 -0800
parents 0055d0b8a4bb
children 8561ecc44317
line wrap: on
line diff
--- a/doc/interpreter/Makefile.am
+++ b/doc/interpreter/Makefile.am
@@ -164,13 +164,7 @@
 	@$(GREP) '#define HAVE_UMFPACK 1' $(top_builddir)/config.h > /dev/null || { echo "Documentation creation requires missing UMFPACK library.  Cannot package distribution!" ; exit 1; }
 	@$(GREP) '#define HAVE_QHULL 1' $(top_builddir)/config.h > /dev/null || { echo "Documentation creation requires missing QHULL library.  Cannot package distribution!" ; exit 1; }
 
-# Install doc-cache of help files
-install-data-local:
-	$(MKDIR_P) $(DESTDIR)$(octetcdir)
-	$(INSTALL_DATA) doc-cache $(DESTDIR)$(octetcdir)/doc-cache
-
-uninstall-local:
-	rm -f $(DESTDIR)$(octetcdir)/doc-cache
+octetc_DATA = doc-cache
 
 DOCSTRING_FILES = $(shell $(srcdir)/find-docstring-files.sh "$(top_srcdir)")