diff configure.in @ 2674:5a9e08ddc093

[project @ 1997-02-13 22:30:38 by jwe]
author jwe
date Thu, 13 Feb 1997 22:30:39 +0000
parents 042f5cbdb2a8
children 5b13fb88db90
line wrap: on
line diff
--- a/configure.in
+++ b/configure.in
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.252 $)
+AC_REVISION($Revision: 1.253 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -375,16 +375,28 @@
   SHARED_LIBS=false)
 AC_SUBST(SHARED_LIBS)
 
+AC_ARG_ENABLE(rpath,
+  [  --enable-rpath          add -rpath to link command for shared libraries],
+  [if test $enableval = no; then use_rpath=false; else use_rpath=true; fi],
+  use_rpath=false)
+
 DLFCN_DIR=
 CPICFLAG=-fPIC
 CXXPICFLAG=-fPIC
 FPICFLAG=-fPIC
 SHLEXT=so
+RLD_FLAG=
 case "$canonical_host_type" in
   alpha-dec-osf*)
     CPICFLAG=
     CXXPICFLAG=
     FPICFLAG=
+    RLD_FLAG='-Xlinker -rpath -Xlinker $(libdir)'
+  ;;
+changequote(,)dnl
+  i[3456789]86-*-linux*)
+changequote([,])dnl
+    RLD_FLAG='-Xlinker -rpath -Xlinker $(libdir)'
   ;;
   rs6000-ibm-aix* | powerpc-ibm-aix*)
     CPICFLAG=
@@ -399,6 +411,7 @@
       FPICFLAG=+Z
     fi
     SHLEXT=sl
+    RLD_FLAG='-Xlinker +b -Xlinker $(libdir)'
   ;;
   *-sgi-*)
     if $use_g77; then
@@ -406,6 +419,7 @@
     else
       FPICFLAG=-KPIC
     fi
+    RLD_FLAG='-L$(libdir)'
   ;;
   sparc-sun-sunos4*)
     if $use_g77; then
@@ -420,8 +434,16 @@
     else
       FPICFLAG=-PIC
     fi
+    RLD_FLAG='-Xlinker -R -Xlinker $(libdir)'
   ;;
 esac
+
+if $use_rpath; then
+  true
+else
+  RLD_FLAG=
+fi
+
 AC_MSG_RESULT([defining FPICFLAG to be $FPICFLAG])
 AC_MSG_RESULT([defining CPICFLAG to be $CPICFLAG])
 AC_MSG_RESULT([defining CXXPICFLAG to be $CXXPICFLAG])